Particle events down for anyone else?

None of the publishes from my devices are working. Looking at the events stream for my account on the console shows nothing (even after an extended amount of time). I tried flashing a device to publish a random event every 2 seconds and that isn’t coming through either. Usually when you reset a device, it should have an event when it comes back online but there aren’t any of those events either. I am not sure if it is just me or the whole events service is down (which is unlikely right?). Nothing is wrong at the moment according to . I’ve also tried just accessing the event stream in the browser using: but that comes back with HTTP ERROR 429. Is it a problem with my network? Any help would be much appreciated. Thanks!

EDIT: Seems to work now.

1 Like

Obvioulsly "self healed" :wink:
But have you seen this heads-up about subscribing to the public event stream?

Hey ScruffR, Thanks for pointing that out. I’m not exactly sure how the deprecation may affect me. Does it mean I’ll have to change the publishes from my devices to be PRIVATE as opposed to right now I have left that field blank (so PUBLIC by default). Or does it mean I’ll have just have to change the way I subscribe to events.

Also, my events seem to be down for me again. Trying to view in console is still blank. I’m confused as to whether this is only for me. Please advise.

You wrote

And hence the deprecation would render this attempt to investigate the issue futile as it would be meant to fail.

Also in future (0.8.0+) the scope parameter won't be optional any more but must be provided as either PUBLIC or PRIVATE.

BTW, in order to avoid spamming the public eventstream it would be good to go PRIVATE anyway

Ah right I see, that makes sense. However, viewing from Particle Console should still work right? Right now I’m back to seeing 0 events even when I force a device to do so. Is this happening to you as well?

EDIT: Nevermind, it’s back. This is such a weird thing. Anywho I’ll take on the advice to make all my events PRIVATE. Thanks alot.

I don’t see any hickups with my events.

Could it be that you run into situations where you don’t have the required delays between publishes and hence your publishes get muted due to the rate limit?

Also on startup your device will issue some status event publishes which also count against the rate limit.

If you are getting a 429 error, you may be making too many API requests from your IP address, not exceeding an event limit. This includes all API requests, so for example polling a variable on a device can cause the limit to be hit. The limit is somewhat vague, but I’d try to keep the number of API requests under 40 per second, I think. This is per public IP address.


@rickkas7 If I reach this limit, Console should still work and display all my publishes right? In my case, Console always works (not http error codes), its just that events stop showing up. I’m also quite sure all my devices have appropriate delays between publishes, although I’ll go and double check.

I’m just wondering if there is something in particular that I’m doing that would cause all events in my account to stop working, as opposed to a singular device being muted.

EDIT: Actually, I switched to a different public IP and all events were going through fine. I guess that means a server or something on my IP is doing too many API requests? Does that include Particle function calls too often?