Particle Electron Flashing Red Will Not Enter Safe Mode, Fried?

This morning I attempted to set up my Electron to record data from a professional-grade solar panel. I was getting some readings that looked off, so to test it I tried different resistor circuits (I am using a voltage divider circuit so that I am not just getting 4095 the whole time in peak sunlight). I then decided to take out the resistors and try plugging the wires from the panel directly into the Electron via the breadboard. One of the wires was having trouble going in, so I spent a few minutes trying to fix that so it would insert smoothly, but when I tried to plug it back in I noticed that the Electron had gotten so hot that it hurt to touch it for longer than 3 seconds and it was flashing red in a pattern that resembled the SOS pattern. So, I went to the documentation and it told me to put it into safe mode. I had to use two screwdrivers to press down the buttons because the device was so hot, but after releasing the RESET button all I got was a flashing red light that went on forever. I’ve unplugged, replugged, tried without USB charging, tried with only USB plugged in and attempted to enter safe mode for about 10 minutes in total. I fear that I may have fried my Electron, and I am not sure what to do to fix this.

Could you post a video of the Electron flashing red?

Also, are you able to put the Electron into DFU mode?

Yep you probably fried the Electron from High Voltage.

Here is the cheapest INA219 voltage current sensor I could find for you.