LTE Electron Error of super flashing in SAFE and DFU mode, won't connect


#1

Hi Particle forums,

Having trouble with an LTE Electron where, there is no green or cyan in normal mode, no flashing at all. And also where there is a super fast (flash - flash - flash etc) too fast for camera to capture, status LED in SAFE Mode and DFU Mode. The colors are correct, but the flashing is very odd, again, its much faster than shown here, frame rate could not keep up (30 fps in the video)

Also, in DFU mode, I was unable to upload software -> did not recognize the device
And I am unable to put it into listening mode to get Particle ID information.

Any guess on what’s happening here?

Thanks!


#2

Typically 5 sec is too short to deduce anything really.
30sec is usually a good time frame to get a better feeling for what’s going on.
How long did you let the device sit there doing its part?

What host OS?
Have you tried a different cable?


#3

Hi ScruffR,

I tried another cable to attempt to flash firmware when the device is flashing Yellow in a weird way, but appears to be DFU - ish mode. I get an error saying no devices in DFU mode can be detected. Same as the other cable.

Good news! longer video -> much longer actually, this is 1/8 of a second slow motion. This is good because it allows you to see the distinct rapid flashes of the SAFE Mode purple light.

The device will keep doing this continuously. And also note there is a matching yellow flashing sequence to SAFE Mode when you press the keys to go to DFU mode. Only the light changes to Yellow.

Those are the only lights, there are lights when in normal mode where you would expect to see a Green blinking. The status light is just completely off in modes other than SAFE or DFU


#4

You should not try to run the device without cellular antenna - the cellular module is not designed to run without load.
You may also want to remove the Electron from the breadboard in case it has some issues (there were some instances of bad breadboards).

I also repeat my question

(Windows, Linux, MacOS, …)

The magenta blinking may suggest the attempt to auto-upgrade the device OS but without cellular antenna the device would never be able to connect to the cloud in order to pull the update OTA.


#5

Hi ScruffR,

Windows is host OS.

For reference, here’s a photo of what it looks like plugged in with Battery, without me trying to put it into SAFE mode or DFU mode. No Status light action, just dark.

Ah, ok I did not know that about the antenna, I have added the LTE antenna. No change.

I put the device into safe mode. using the mode and reset. Which is why its purple.

It could look like trying to connect to data, but that’s not what’s happening here.

Thank you for your help!

We just got 150 of these from particle, and 1x of them had this error. I’m not sure if other folks have had the same issue. The 149 other units worked just fine.


#6

While 1 DOA out of 150 is not an expected ratio it might still be bad luck and you got a dud and I’d file a support ticket for that - especially when this issue was there out-the-box.
If it wasn’t it would be good to know what happened to the device prior to it.

Does the device show up in Device Manager at all - anywhere - when put in DFU Mode?


#7

Hi ScruffR,

It does not show up at all in device manager when it is in this fast flashing DFU mode.

I have a good Electron with me, and can confirm it is able to connect to and shows up in my device manager. So I know what I’m looking to not be there.

I’ll send in the ticket. Thanks for your help!