Particle Electron: flashing cyan and orange

Hey guys. Having some trouble with the Electron. Getting cyan and orange flashing rapidly on two of the board’s LEDs. Any thoughts? I’ve looked around at some posts and have tried particle keys server, particle keys doctor, particle update with no luck. Each command appears to run successfully but the constant orange blinking remains.

Here’s a video of the blinking:

That might be what other threads here call “red/orange burst”

And the usual cure in all of these threads is

particle keys doctor <yourDeviceID>
particle keys server
1 Like

Doesn’t seem to help. The flashing starts as soon as the device turns on, and nothing I can do seems to stop the orange light, but I can change the other light, i.e. go successfully into safe mode, DFU mode, etc.

Those commands seem to successfully execute though.

Have you had the device in DFU Mode and connected to your computer when you executed the commands?
What’s the output?

Or do you mean the charging LED?
Try plugging in the LiPo :wink:

Without the LiPo connected USB will not deliver enough power (quick enough) for the cellular modem to be able to connect.

On initial view of your video I focused on the RGB LED and thought I saw the red/orange burst there, but the seperate red is only the charging LED.

Ah! That’s fixed the orange light. Now I only have rapid cyan. Is there a common cure for this as well?

The rapid cyan is usually a by-product of not enough power for the cellular module. Is the LiPo properly charged?

If you are not sure, double tap the Mode button to send the Electron into sleep to speed up the LiPo charging, give it half an hour and see what’s happening then.

On double tap, the RGB LED should turn white, then dim white and finally off (if it doesn’t your device might want a firmware update).

But hold a sec’. Is the charging LED on or off now?

The LED that was previously flashing orange rapidly is now off - now the only flashing LED is the one b/wn MODE and RESET, and it’s flashing cyan rapidly. I put the Electron to sleep to give the LiPo some time - will test again soon.

It should be on while the LiPo gets charged and off when the charging currrent drops below 10mA (AFAIK).

So you might want to unplug USB and hit RESET and see what happens then.
After a while, plug in USB again, then the red charging LED should come on solid for a few minutes.

With the battery plugged in and no USB, the only LED that’s on is the RGB (flashing cyan). When I plug in the USB, nothing changes.

That rapid cyan is the indication of a Particle cloud handshake which only happens after your device has got a cellular connection and a valid IP.
So that’s a good sign.

Let it do that for a few minutes (>10) without USB. That should definetly drain the battery enough to have the red LED come on when powered via USB again.
If it doesn’t try some other USB power source.

1 Like

I left the Electron running on the battery for a while - then connected USB and let the board sleep for a while, and the charging LED came on. After about 5-10 minutes the charging LED turned off, I reset the board, and now I’m back at rapid cyan.

Occasional red-orange blink occurs on the RGB LED (once in the last 10 minutes)

Is it possible that it’s an issue with the LiPo? It looks like it wants to connect so badly. The cyan blinks so rapidly.

If the device is running (even only flashing cyan) for a while off the LiPo, that shouldn’t be an issue.
The occasional red/orange burst shouldn’t matter if it’s really only once in 10 minutes.

So there’s most likely something else.
Could you try to put the device into Safe Mode now with the LiPo attached?

You could also flash this troubleshooting binary and post the serial output

If your device isn’t yet upgraded to 0.5.1 or higher, you should do that first

particle update
particle flash --usb electron-troubleshooting-v0.5.1.bin

I have an Electron doing this same thing. Here is what I did:

  1. The Electron was going going through different states: blinking cyan, then blinking orange, then blinking green. It would cycle through this process.

  2. Performed the particle keys while the device was in DFU mode

    particle keys doctor

Then I get this:

Found DFU device 2b04:d00a
Found DFU device 2b04:d00a
Error creating keys... Error: Command failed: C:\Windows\system32\cmd.exe /s /c
"openssl ecparam -name prime256v1 -genkey -out 21002800025hidingkey _ec_new.p
'openssl' is not recognized as an internal or external command,
operable program or batch file.

Make sure your device is in DFU mode (blinking yellow), and that your computer i
s online.
Error - Error: Command failed: C:\Windows\system32\cmd.exe /s /c "openssl ecpara
m -name prime256v1 -genkey -out 210028000251hidingkey_ec_new.pem"
'openssl' is not recognized as an internal or external command,
operable program or batch file.

then performed: particle keys server , and go this:

Found DFU device 2b04:d00a
spawning dfu-util -d 2b04:d00a -a 1 -i 0 -s 3298 -D C:\Users\fishmastaflex\AppData
dfu-util 0.8

Copyright 2005-2009 Weston Schmidt, Harald Welte and OpenMoko Inc.
Copyright 2010-2014 Tormod Volden and Stefan Schmidt
This program is Free Software and has ABSOLUTELY NO WARRANTY
Please report bugs to

Opening DFU capable USB device...
ID 2b04:d00a
Run-time device DFU version 011a
Claiming USB DFU Interface...
Setting Alternate Setting #1 ...
Determining device status: state = dfuIDLE, status = 0
dfuIDLE, continuing
DFU mode device DFU version 011a
Device returned transfer size 4096
DfuSe interface name: "DCT Flash   "
Downloading to address = 0x00000ce2, size = 320
Download        [=========================] 100%          320 bytes
Download done.
File downloaded successfully
Invalid DFU suffix signature
A valid DFU suffix will be required in a future dfu-util release!!!
Okay!  New keys in place, your device will not restart.

Then pushed new firmware.

  1. After firmware push, it’s current state is rapidly blinking cyan.
  2. I tried different LiPos, same thing rapidly blinking cyan state.
  3. Performed a particle update, same rapidly blinking cyan state.

EDIT: Fixed! I mistakenly ignored the openssl error messages and found out that I needed to add the path to my Windows environmental variables.

After doing that, I ran particle keys doctor again. That fixed it.

1 Like