Particle Dev wont work, but Build does

I have a very weird problem.
When I flash code from Particle Build, it works great and my core is following the new code.
When I try to flash code from Particle Dev, it shows like everything is good (Got success and flashing magenta and than cyan ), yet the core is still running the previous code! (the one I used Particle Build to flash).
I am trying to flash basic programs, blinking led, so I don’t think that’s the problem.
Anyone have any idea what can be the problem? I tried factory reset but didnt help.

There are several possible reasons

  • you have selected a different project folder than the one where your edited file lives in.
  • you just pressed the flash button but already had a binary file in your folder (press the cloud button first, then the flash)
  • you haven’t saved the edits (unless auto-save was already added) - check for the cyan dot in the file tab

Sometimes showing a screenshot of your full Dev window gave us some other clues.

I fixed it by a factory reset.
I have a diffrenet question, I wanna use serial.print to test stuff, debug printing and printing my sensor data to see if stuff are going good, but I dont understand where I can see the output of the serial.print


You’d need to open a serial monitor like PuTTY or you could use

particle serial monitor