Particle dev , dfu-utility not work?

I use electron 3G-270.

When I compiled firmware on particle dev or dfu-util,
Flash succeed, but Device Modes breathes magenta.
But,a same source code worked in today’s morning.

On the other hand,I compile firmware on Particle Dev is working correctly.

Is it different from particle dev compiler and particle build compiler?

Could this be due to the device trying to auto-update since system version 0.5.0 was released today?

Unlike Wi-Fi devices, Electrons don’t auto update system firmware due to the data consumption.

But it does sound like safe mode - you’ll need to update your system firmware, as described here Particle Firmware Updates Thread

This can happen if you compile in Dev, which will select the latest version by default.

1 Like

thank you!
I tried system update. And I use particle dev command,Now System is working normarly.

You may want to try the script I created. It installs the the Particle toolchain and dependencies for you, and makes it easier to build your code.

Build Status