Particle Dev compiler errors inconsistent

But Particle Dev does not work at the moment…
Just try to compile something simple:

#include "missing,h"


and You won’t get a correct error message !!!
could anybody from Particle comment on this ?

If I’m not mistaken, Dev is currently being worked on to iron out some of these kinks. Not entirely sure, so don’t pin me down on this :wink:

Also, that error is true, it can’t find that file, for it does not exist(?)

Having fixed the comma, and created the file, the following two errors seem pretty legit as well:

Which firmware version have You compiled for ? Compiling for photon 0.6.2 in my setup it answers "Compiler timed out or encountered an error ". When I compile for 0.5.2 it gives the correct error. There must be some error in the script that parses the compiler output.

You are right about my typos. But when i try to compile for Photon 0.6.2:

void setup() {

void loop() {

i get "Compiler timed out or encountered an error "

Seems to work for me?

It seems if I cleanout the directory of the project it works. But if I add a subdirectory for a library it gets awful again. It is inconsistent. It seems with a file named in the top level dir it will fail again… but only for 0.6.2 when I compile for 0.5.3 it will complain correctly about a missing header-file. the compiler toolchains behave differently with the same error in the source

Do you get the same error when building with particle-cli?

I was having this issue last week with Particle Dev - same empty error pop-up for 0.6.2. Compiling for 0.5.3 produces a useful error pop-up. Building with the CLI was the only way to get any error data. This was also the case for a “fresh”, empty project.

1 Like

If You select “start a new project” from the particle dev. Then insert #include “missing.h” to the .ino file and compile You will get "Compiler timed out or encountered an error "

if I remove the file and compile i will get a correct error-msg.

But what does particle-cli say?

It mentions the missing file.`

1 Like

particle-cli works. But in particle dev some scripts handle the input-files and the compiler output and we don’t get the raw compiler output if these scripts fail.
These scripts get confused by the file.