Particle Dev shows no details for compile errors

I have been having a problem this week where Dev does not give any details on compile errors. No mater what the error it just spits back “Compiler timed out or encountered and error” I have been having to compile and paste the code in to Build to find the error, once the are corrected in Dev it compiles and flashes without problems. This is happening on two different windows machines. Yes i have tried logging out in Dev and back in.

Any suggestions?

1 Like

No idea about Dev, but you can always use CLI to build your local project, without the need to copy-past into Web IDE.

@Raelx, What worked for me is a slight variation on what you tried. Make sure you update CLI to the latest version. Then make sure you are logged in on CLI. Then login to Dev. After doing that, it worked for me.

My assumption is that Dev uses CLI to do the compiling, which means you need the latest versions for Dev and CLI to play nice together.
Let us know if that works or not.

Nope, Dev doesn’t use CLI but uploads to the same build farm as CLI and hits the same API endpoints.

Only problem here is i don’t have the CLI installed and have never used it.

I do like the Dev environment, when it works. Atom is solid and then it’s one click to compile and OTA flash.

Installed CLI, logged in on that, logged out on both, logged back in on Dev. not change. This problem is making Dev almost useless as a tool.

Can you build your project with CLI?
cd into the project folder containing the project.properties file and execute (assuming Photon as your target platform, since not explicitly stated)

particle compile photon .

(the final dot (.) denotes the current directory - so it’s there on purpose :wink: )

Yes it will compile in CLI and will show errors, say one missing semicolon. Where in Dev it just throws the error “Compiler timed out or encountered an error” for the same missing semicolon.

Doe anyone know where Dev stores your login and user data? if i uninstall and reinstall Dev after the install it starts up in the last directory and I’m still logged in. I would like to figure out how to clear all this to see if that is the problem.

I have been experiencing the same problems these past few days.

@Raelx I had similar issues and have reverted to editing with Particle Dev, but compiling from command line CLI. There are several things not working well with Dev, but the code editing features are much better than the web IDE or Sublime so I still prefer that. It would of course be neat if Dev just worked, but I can live with CLI compilation.

I have been having the same problem for a few weeks. I found that in the latest version of Particle Dev, if you change the build target to 0.5.3 (some others work also) errors are reported. Although the CLI may have more complete error reporting and of course you’re building against the most recent build target, it’s just a little more convenient to stay in Particle Dev.

1 Like

@rvess That’s confirmed. I had similar results. Under CLI, all releases compiled and reported errors. Under the Atom IDE, v1.8.0 (current) I experienced the following:
0.62 RC2 - "timed out"
0.62 RC2 - "timed out"
0.62 RC1 - "timed out"
0.61 - "timed out"
0.61 RC2 - "timed out"
0.61 RC1 - Reported errors in Atom IDE
0.60 - "timed out"
0.60 RC2 - Reported errors in Atom IDE
0.60 RC1 - Reported errors in Atom IDE
0.53 - Reported errors in Atom IDE

So it appears something broke in Particle Dev build around 0.60 or 0.61 RC2. Would be nice to fix in the next update. So until then, will have to use CLI to see compile errors.

1 Like

Thanks for the confirmation,
I was beginning to think I had something configured wrong!

One thing I noticed is that the particle-dev package that gets installed using ParticleDevSetup.exe is 0.1.20 and is not yet updating to 0.1.22. I installed Atom and all the particle-dev packages on an Ubuntu VM including particle-dev @0.1.22 and everything worked as expected. I don’t know if that has anything to do with this problem, but yea the next release of ParticleDevSetup.exe or particle-dev package updating to 0.1.22 will probably fix things on Windows!

I experience the same problem, is there already a working solution?

Check out this github issue, in it suda commented:
“This bug has been fixed in the particle-dev package itself but the standalone Particle Dev App hasn’t been updated yet. We’re going to do it this sprint!”

https://github.com/spark/particle-dev/issues/211#issuecomment-316734115

1 Like