Particle Desktop IDE - Can't log into Particle Cloud

When I select “Click to log in to Particle Cloud” in Particle Desktop IDE, enter my email and password (the ones I use for, and hit “Log in”, I get the message

Error: tunneling socket could not be established, cause=connect ECONNREFUSED

This happens on my laptop. I also have Particle Desktop IDE on my desk PC, and I am able to log in with no problem.

I am running Windows 10 on both platforms.

Is there a problem with having Particle Desktop IDE on two platforms at once? I don’t need it on my desk PC.

Thanks for any help.

It looks like your laptop is configured to use a tunnel or proxy that is not currently running.

Also make sure the environment variable http_proxy is not set, as Atom will use it, I think.

You can have as many copies of Particle Dev, CLI, console, and Particle build running as you want.

I don’t have Internet Explorer on my laptop. Could that be the problem?

Not having Internet Explorer/Edge is fine. Something configured on your laptop is redirecting your https traffic from directly connecting to the appropriate site (probably to some sort of internal proxy that’s not running.

May be just a coincidence, but that port is also used by SpyBot to redirect your traffic - have a proper malware scan of your computer!


Got it to work!

I DID have Internet Explorer on my laptop, I just hadn’t used it.

When I brought up IE, I got a similar proxy server warning to the one on Particle Desktop IDE.

I found a correction for that problem at

I followed the directions under STEP 1: “Restore the default proxy settings to your machine”.

That fixed my problem with both IE and Particle Desktop IDE.

1 Like