Particle cloud registration issues? Stuck on rapid Cyan blink (0.6.0/RC2)

I’ve consistently been seeing the rapid cyan light with a batch of Particles that I’m building.

Has anything changed in 6.0.0, or to the particle cloud limits re online devices or anything like that?

I understand rapid cyan is a) its found and auth’d to wifi b) its looking for the particle cloud / testing internet. Could someone please confirm?

Symptom, rapid green like normal switching to rapid blue, but stays on rapid cyan instead of settling to slow breathing (ie connected). Only ‘fix’ seems to be wait a few mins and cycle power, rinse repeat, until it connects within a few seconds like normal.

I’m getting a lot more reports of wifi stability issues as well from customers. I’m an experienced network engineer and the pattern of reports from customers who have been up and running happily for months and then encounter drop out issues is starting to concern me re firmware etc.

While I’ve typed this I had a board on the table in rapid blinking. Had powered it off, powered it back on when nearly finished this post and it connected in seconds like normal.

Can upload a video of the blinking symptom, but I’m sure folk know what i’m talking about.

Nothing that I’m aware of that would cause this intentionally (e.g. limits).
Is this happening to 0.6.0 devices only, or are other versions affected as well?

0.6.0 RC1 seemed to be fine, been using that for months. This has only cropped up in the last week or so, roughly 0.6RC2 timing.

It’s bizarre. I have 15 upgraded (0.6.0), wifi connected, claimed, flashed, renamed etc boards on the kitchen table. They were fine last night, though I did notice one that did the rapid cyan, same symptom.

However this morning 50% of the boards won’t connect first time. It’s not the kind of strike rate you want when you know they should be rock solid!

ps, I have a dedicated wifi router for Particle photon setups, large DHCP lease range (which once caught me out on my personal one!), rebooted it to clear dhcp leases for good measure, still get the same strike rate. Pretty sure its not anything in my internet path thats deciding to deny connection randomly.

It really does seem like a primitive rate limit on particle cloud, or a bug, or something astronomically stupid on my part, but you know, trained network professional and all.

2f0052000a51353335323536 < particularly consistent problem child. can power off, turn another particle online, go back to it, power it on and get the rapid cyan. power cycle it and sometimes it comes good.

Are you seeing a single (maybe 2?) red flashes about every 20 seconds or so, in between the rapid cyan? That’s what I’ve been experiencing off and on over the last week or so. It was doing it on 0.5.3, and it’s still doing it on 0.6.0. There is a discussion about it here.

1 Like

I did! about 30 seconds in, which for me is when I force listening mode if it hasn’t connected

many thanks Ric, glad i’m not crazy, and there is a bit of ground swell showing the pattern. my guess is load balancing to a server that can accept the new session. it keeps hammering away trying to connect (rapid cyan) but there is no love from the load balanced node

Have things calmed down again for you?
Particle is looking into it (maybe already fixed)

Less often, it was observed 2 hours ago

I got this mail yesterday. Maybe it has been solved?
I experienced similar issues, I’ll check if the problems have been solved

1 Like

I’ve been flashing usb firmware / setting up wifi / claiming / flashing firmware to a few devices and seems to be ok tonight.

1 Like

Yes, same here!

Glad to hear! We also worked with the engineers offline for a brief check on the health hours after the incident to make sure you guys are up and running well :wink:

3 Likes