Particle CLI Setup Issue >> Path Error and ParticleSetupDriver

When attempting to install the Particle CLI in Windows i get the following error:

path not updated original length 1038>1024 particle

after hitting ok, I get another error saying “Error opening filing for writing: ParticleDriverSetup.exe”

Help is greatly appreciated.

I guess your PATH environment variable is somewhat massive.
You may want to check that and either remove some unnecessary parts from it or split it in parts via a secondary variable.


Thank you for the reply! I was able to successfully load the CLI, USB drivers using the Windows Installer on another computer. I’m now unable setup the device. When I type particle setup in the CMD and have the elctron in listening mode I get a “No devices detected via USB” error. As a further note, when I put device in DFU mode, “Photon DFU Mode” shows up under libusbK USB Devices.

I guess this isn’t Win10.

With Windows prior to 10 you need to install serial drivers (which should have been installed via the installer as long the respective check box was ticked).
But if they weren’t you can download them from here

BTW, your Photon must be running Device OS version >= 0.6.0

BTW², have you tried updating the driver via DevMgr? You have an Other devices - Electron Serial which indicates there is no valid driver assigned to that device.

I ran into the same issue today and the forums were a little thin on solutions…thank goodness for @ScruffR. Keeping it in this topic for anyone who experiences the same error message of “PATH not updated” when installing CLI:

I followed the directions from the link that suggested:
" The easiest is to use Rapid Environment Editor. This free utility will,

  1. Remove the duplicate paths (right click > Cleanup Paths)
  2. Remove non-existent folders (shown in red which you need to manually delete)"

Worked like a charm in less than 5 minutes. And oh, you wonder if CLI will run fine with the PATH error? No, it doesn’t. Some stuff works…but some things don’t so you’ll be chasing your tail in frustration if you ignore this error message.

1 Like