Particle CLI fails silently on M1-based Mac (macOS 11.2.3)

Hi all,
I just tried installing Particle CLI on my new Mac Mini M1. It installed fine via the command line script with no errors. Opening a new Terminal window typing “particle” on the command line produces no output. The program executes, but you don’t get the normal help listing that shows the additional commands. There is just no output and the command returns for you to type in a new command.

This happened just as my CLI login on another computer failed and I was in the middle of a lecture trying to explain why Particle is such a great product. Needless to say - the attendees were not impressed. I would however like to get this resolved before my next lecture in a week, so any pointers as to why this would fail and is such (a silent) way is much appreciated!

Got this solved after some fumbling. I had to uninstall using the global flag:

npm uninstall -g particle-cli

and then reinstall with:

npm uninstall -g particle-cli

Very odd behavior. Never seen this before, but hey - it now works!

Are you running your terminal with Rosetta?

Nope. I used the default.