Particle cli and photon issue with self signed certificate

Does anyone know if there is a way to get the particle cli to ignore self signed certificates?

I am on an enterprise network where the corporation intercepts all traffic and uses their own self signed certificate. This creates issues when attempting to do most things in the particle cli that need access to the cloud.

I also believe this is causing cloud connection issues with the photon I am testing with so if there is a way to disable certificate checking in the cli is there any way to do it on the photon as well?

I am using a windows machine with Particle CLI if that helps anyone.

That’s an unsupported configuration and you’ll likely have difficulty getting it to work.

However, you may be able to get it to work by turning off TLS authentication in node.js, which is not recommended because it’s inherently insecure.





You may have to manually install the Particle CLI from a command prompt/terminal window, because it might be hard to get the installer to use the overridden default. Setting it as an environment variable might work.

The Photon should work because it doesn’t use TLS/SSL authentication. It uses RSA keys and AES authentication with CoAP. As long as the network allows outbound TCP 5683 (CoAP) the Photon should work.

1 Like

Thank you very much for the information that was what I needed.