Particle Dev: Error: self signed certificate in certificate chain[RESOLVED]

I am having a Particle Dev login error that I can’t resolve. I get the following on login attempt “Error, self signed certificate in certificate chain” I have uninstalled and reinstalled Particle Dev, same error. I created a new user account on my computer, downloaded Particle Dev and attempt to login but still get the same self signed certificate in certificate chain. Anyone have a clue on how to fix this? I would hate to think I needed a totally new Particle account, reregistering my Photons to this new account to resolve. BTW, the Build IDE seems to be working fine but I need Dev to follow implementation guide codes from SparkFun. Thank you in advance for advice.

Ping @suda

So I found a solution to this error message on OS X 10.10.4.

I am not going through any proxy servers which was one possible cause of this error message as suggested by a Particle engineer. However, if you look at the youtube link below to fix intermittent wifi connection issues on the latest OSX version it resolved theself signed certificate in certificate chain log on issue. Basically, I inactivated my current wifi connection in network settings, then created an new wifi connection, called it wifi2, logged back into my wifi router, opened Particle Dev, logged into the Particle cloud, no problem.


@wmjenk It’s great to hear that you solved it! I would be cautious though. You might of caught a virus that hijacks your DNS settings (yes, unfortunately Macs are no longer virus free). I would recommend scanning your system with some antivirus software.

That was my thought as well. I have done a complete scan with Kaspersky using the latest virus database and no threats identified. I will keep checking and be cautious of any unusual behavior.

1 Like

@suda, so the issue is returned and although I was able to login once I never was able to see my three registered photon devices. I repeated the wifi connection delete and created a new wifi connection and now I get the error again. I have used several tools looking for DNS hijacking software but have found none (so far). Any suggestions as I am stuck? I did test from another wifi and I still had login problems. I also tested on the same computer from a new user and still had login issues. I also used another mac within the same network and I was able to install and login to the Particle Cloud with Particle Dev on that Mac. So, it has to be something on my computer. I deleted a number of certificates in keychain access and still no luck. I have scanned with virus and dns hijack tools, no identified issues.

Finally, I used the Console to watch what was executing while launching Particle Dev. I identified an unusual error which I searched Google on and found a discussion on Apple Support related to Yosemite. Basically, there were some residual malware/addware related files that once remove and the computer restarted finally fixed the issue. WHAT A PAIN, but the issue is now resolved. BTW, I tried Kaspersky as well as a couple of other virus/maleware/adware detection programs and none caught the issue.

If someone else has these issues on OS X check out these links:

Also note that if you have the https checking feature turned on with Kaspersky Internet Security it will also cause this error. See:

1 Like

Wow! That is a pain! Could you share link to Apple Support in case someone else runs into the same issue?