P1 / Sparkfun Photon Redboard stuck [Solved]

Hi there. I got an old Sparkfun Photon Redboard (P1 module) out of storage and tried to use it for a project today.
But, it seem that it is totally stuck, and I cannot get it work no matter what.

If I use the CLI to do ‘particle serial wifi’, it just gets stuck trying to set up the wifi credentials:

? Should I scan for nearby Wi-Fi networks? Yes
? Select the Wi-Fi network with which you wish to connect your device: MatrixAlma
? Should I try to auto-detect the wireless security type? Yes
> Detected WPA2(PSK/AES/AES) security

Saying no to the scan also leaves it stuck on the first step, and I am not asked for the SSID.
I have tried re-flashing the firmware by using the 0.5.2 “Firmware Manager” app. The reflash appears to work, but the same behavior persists.

I have tried manually flashing down to 0.5.0 also. The same problem as above remains.

Any ideas?

Might be worth it to try upgrading by placing the unit in DFU mode and then issuing the command particle update followed by particle setup once it’s back in listening mode.

If that doesn’t work let me know and we can try a different WiFi configuration method using a serial terminal like CoolTerm or putty

Still doesn’t work.

On OSX, if I do particle update and then particle setup, it will detect the P1, and then hang waiting for it to enter wifi setup mode, at:
Waiting for a wild Photon to appear...

If I do it in my Windows VM, it will skip that step (since as far as the VM is concerned, there is no wifi adapter), and it will let me to manual wifi credentials entry. However, using that method, the setup then hangs on the final part:

? Would you like to manually enter your Wi-Fi network configuration? Yes
? Please enter the SSID of your Wi-Fi network: mynetwork
? Please select the security used by your Wi-Fi network: WPA2
? Please enter your Wi-Fi network password: mypassword
> Here's what we're going to send to the Photon:

> Wi-Fi Network: mynetwork
> Security: WPA2
> Password: mypassword

? Would you like to continue with the information shown above? Yes

> Obtaining device information...

> Obtaining device information...

Trying manually: doing screen /dev/tty.usbmodem1411, and typing and ‘i’ or a ‘w’ does not yield any result.
And trying the same with putty in the windows VM also does not work.
I have no idea what I did to screw this thing up …

I don’t believe it should matter but try another particle update but follow it with particle flash --usb tinker to bring everything to factory-fresh.

1 Like

Nothing works :frowning:

Well, some things work. I took the board back to the place I used to live, where I initially set up the wifi … and it logged back onto the network. I can even flash it from the the online IDE. And serial even works, when I do a simple serial test program.

But no matter what, I just cannot get it to reconfig the wifi credentials. I can’t even get it to reset the wifi credentials, since there is only flashing magenta and flashing yellow when I hold the ‘mode’ button.

The credentials reset works different to entering Safe or DFU mode.
For these two you hold the SETUP button and tap RESET, but for Listening mode and consequently WiFi reset your device needs to be powered already and no RESET is hit while you press and hold SETUP.

And have you checked that your new network fits the requirements?

WEP encryption is possible but the key entry needs some extra attention.

Aha, that worked. It does say that in the SparkFun tutorial:
“The MODE button can also be used to place the Photon in listening mode (to re-configure WiFi, check the firmware version, or module identity), while an application is running. To accomplish that, hold the MODE button down for about 4-5 seconds, until the RGB LED begins blinking blue.”

… but it is right under a video of them doing the two-button mode change.

In listening mode, the device acts as expected, I can set it up with particle setup , or particle serial wifi, or over the serial terminal.
Good, good, my board isn’t ruined, I was just using it wrong.


Glad you were able to get it back up and running @apullin! Thanks for the help @harrisonhjones @ScruffR!