P1 part number: WM-N-BM-14 Vs WM-N-BM-14-S


#1

Hi!

My latest board is in production, and the p1reel part I specified has turned up at their factory, and they are asking me to validate that their “WM-N-BM-14” part marking is correct.

Should it not be with an “-S” at the end, namely a “WM-N-BM-14-S” part?

I’m worried I might not be getting a particle P1.

I want to hold off authorizing the run until I know for sure.

Can anyone shed any light on this?

Cheers, Matthew


#2

@rickkas7


#3

The correct part number is WM-N-BM-14-S.


#4

Thanks.

So if something is supplied that is WM-N-BM-14, I should reject it? It’s not a bonafide P1?

Thanks,

M


#5

I just had some prototype boards delivered with the WM-N-BM-14 part and am getting into a weird stack overflow SOS during the wiced connection code that I do not see running the exact same firmware on WM-N-BM-14-S. The assembly house sourced the part as P1REEL. From where, I’m not sure. When they arrived they had a 0.4 version of the device OS on them.

@rickkas7, can you confirm that the WM-N-BM-14 was never a valid P1 module part? Or was it a P1 at one point and, if so, what is the difference between the 14 and 14-S?


#6

The -S version is typically the Particle version (Spark). Submit a support ticket with a few device IDs to find out for sure.

If you buy Particle P1s, the device IDs are already approved for free cloud access automatically.

If you buy USI WM-N-BM-14 directly from USI or their distributors, the cloud access is not included. This costs a few dollars per device to get the device ID approved.


#7

Thanks for the quick response @rickkas7. I’ll submit a support ticket with the IDs to see where they stand. I currently don’t require Particle Cloud access and actually have SYSTEM_MODE(MANUAL); set.

It doesn’t sound like there is a difference in the hardware, only in backend “hookup” to the Particle Cloud. Still makes me curious why I’d get a network-related stack overflow in the Device OS on the 14 and not on the 14-S. Any ideas?


#8

I have been researching this all evening and I was eventually able to get the stack overflows to stop happening by clearing all stored credentials on the module and starting fresh. Perhaps the SoftAP setup got the credentials into a partially saved state or something. Just guessing. Anyway, having cleared the credentials and setting them again via serial seems to have solved the SOS issue. I’d still be interested to know if there is a hardware difference between the 14 and 14-S modules.


#9

I don’t believe there is a hardware difference. I believe the -S version has the Particle logo etched on the top of the can. And the device IDs are granted cloud access out of the box.


#10

Thanks @rickkas7


#11

I also ran into this issue with a recent production run of 500 P1’s that I purchased through Particle. They were preloaded with v0.4.0 and many devices had the same SOS but was fixed by clearing the WiFi creds.

related post:


#12

This was a huge burden to the MFG because each device needed to be put into DFU mode manually since v0.4.0 doesnt support the serial port 14400 to put it into DFU.


#13

This is great information @wesner0019. Thanks for sharing.


#14

@rickkas7 To clarify, does the WM-N-BM-14 come with the exact same device firmware as WM-N-BM-14-S? The only difference is that the WM-N-BM-14 cannot connect to Particle’s Device Cloud without the generation of a device ID?

If that’s correct, how would I generate a device ID for a WM-N-BM-14 device?


#15

If you purchase a Particle P1 from the Particle online store (retail or wholesale), or one of our authorized distributors (like DigiKey), you get a device with a valid device ID and Particle firmware (bootloader, Device OS, and Tinker).

If you purchase a WM-N-BM-14 from USI or one of its distributors, then the device will not have Particle firmware on it. Even though you could flash the firmware using SWD/JTAG, it will not be able to connect to the Particle cloud with it.

Part of the cost of cloud access is included in the price of the P1. Thus you can’t use a less expensive WM-N-BM-14 and still get cloud access.


#16

@rickkas7, thank you for clarifying. I purchased 250 units from Mouser (one of your featured distributors), and they are all WM-N-BM-14 devices. Do these devices all have valid device IDs and Particle firmware, even though they are WM-MN-BM-14 devices?


#17

If you purchased from Mouser you’re fine. Often the devices will be labeled without the -S suffix, even though they have the correct firmware and device ID registration.


#18

That’s good news. Thanks for the quick response!