Original Spark Core online but cannot be "Signal"d or flashed


#1

I have several original Spark Cores and am able to connect to my wifi (happily breathing cyan) and the Core shows up as “having checked in” to the Particle cloud:
in the console (online)
in the Web IDE (online)
in the Particle iPhone app (last heard n seconds ago, correct IP address)

BUT
I am unable to “Signal” it from the Web IDE or to flash it. It does not seem to respond…

What do you think might be the issue ? Seems like it might be something on the Particle cloud side ?

PS: these Cores have worked (and been able to be flashed) in the past, haven’t worked with them for a while, hence my suspicion the error may lie elsewhere)


#2

The last code flashed may be contributing to the issue.
Put the devices into Safe Mode an try again.


#3

Thanks for helping ScruffR !

Using this page as a guide: https://docs.particle.io/tutorials/device-os/led/core/

From my “breathing Cyan” ie “connected to cloud via my WPA2 Wifi” state, I do the procedure to get into safe mode:

  1. Hold down BOTH buttons
  2. Release only the RST button, while holding down the MODE button.
  3. Wait for the LED to start blinking magenta
  4. Release the MODE button

(actually this looks like a factory reset to me cmp https://www.youtube.com/watch?v=nGBSYyTo5xA except MODE is held longer.)

However, I never get a blinking magenta at step 3:
It seems to cycle infinitely between:

  1. blinking green (connecting to Wifi ?)
  2. fast blinking cyan (connecting to cloud ?)
  3. slow blinking cyan once (?)
  4. fast blinking cyan (?)
  5. going dark (?)

After my finger on the MODE button eventually tires out, I let go and the core ends up in
blinking blue (listening mode), from where I can provide the usual Wifi credentials from scratch. After which it happily connects to the cloud again (breathing cyan). Ie back to square one.

I never get the Safe Mode blinking magenta…

Core remains (on trying to flash a sketch from WebIDE: Raw mode output = Device not discoverable or is offline) while Console clearly & reliably notices it going online. Likewise “Signaling” still does nothing as before.

PS I also tried the alternative method of getting into Safe mode: hold down MODE button while booting the Core. It results in exactly the same behavior as above.


#4

Yup, I agree, that is a factory reset - I can’t see magenta at all, it starts with yellow - rather strange IMO.

One other thing you could try is to put your device into DFU Mode and run the following CLI commands

particle flash --factory tinker -v
particle flash --usb cc3000 -v
particle flash --usb tinker -v