Online photons getting listed as offline in the cloud when a core is also online

Howdy,
I’ve been seeing a bug recently where the cloud thinks that online photons are offline. When I restart a photon, it connects to my wifi, and if I run ‘particle list’ in the particle CLI, it correctly shows the photon as online.
If I wait several minutes, the photon is still breathing cyan and running normally, but it appears as ‘offline’ in the particle list results. It’s quite repeatable, and the photon appears as ‘offline’ after a few minutes, basically every time I turn it on. I did a quick test with stopwatch to see exactly when it dropped offline, and it happens repeatedly (3/3 tries) around 2:00 minutes.
I know that the photon isn’t really offline – I can do an OTA flash to the photon, even if particle list shows it as offline.
Is anyone else seeing this issue? Right now, I’m seeing this as a bug in the spark cloud, and if that’s true, it should be plaguing other people, as well. It’s actually quite important for my application that online photons show up as online – we’ve built a website where our users can select a certain device of theirs that’s online (according to the particle API) and flash a custom program to it. Right now, this issue means that photons drop off the site listing a few minutes after boot, which is no good. Any ideas how to fix it?

–alex

1 Like

In an effort to exclude any potential issues with the CLI, which is unlikely, would you mind checking it again by directly calling the API endpoint in your browser? If you open this, it should present you with an overview of your devices: https://api.particle.io/v1/devices?access_token=ACCESS_TOKEN_HERE

Hi Moors7,
Yup, I’m getting the exact same issue with the API endpoint. The photon gets marked as offline right at 2:00.

–me

1 Like

That’s strange. Mine seems to work just fine. Perhaps @Dave can check the logs with your DeviceID. Also, could you check your router DHCP lease times? There’s a very slim chance it’s being thrown out by the router.

1 Like

Hi @enjrolas,

Hmm, do you know which version of firmware you’re running on those photons? Is the connection to the photon definitely still live? (Can you hit a function / see events / etc?)

Thanks,
David

I’m having exactly the same issues. Tried to reconnect to different wifi’s, factory reset. API call shows as offline but shows as last heard at the time of boot. I haven’t done anything with the firmware though.

I have all my Photons listed as connected = false. But they are not, I just called a function of my Photon and it worked just fine. Also last_heard seems to report startup time and nothing else…

Very bad bug since I cant trust the data coming from the cloud.

I’ve tried desperate attempt and reflashed the last firmware from https://github.com/spark/firmware/releases

So far that seems to have helped (device shows online) but I am unsure how long will that take :-/ Fingers crossed…

Experiencing this also - with or without my Core online. Have just updated node.js per instructions from spark to particle CLI, and noticed Photon offline while it is online as I was going to update firmware to resolve wifi issue Photon loses connectivity very often, only reconnects on hard reset

FYI - Core shows up in cli as online in a matter of seconds after Core power-up and cloud connect

Update - after upgrading to Photon 0.4.3 both Photon and Core are showing up as online via CLI… so far :smile:

2 Likes

I’m also seeing my Photon as offline, when it clearly isn’t (since it responds to a function call). It appears offline from my iOS program, as well as from directly calling the API endpoint in a browser. It did appear online in the recent past; I haven’t noticed whether it shows up as offline after a set time. This is happening in the absence of any other Photons or Cores being online.

Hi David,
The photon is running firmware v0.4.1. I can confirm that it’s actually online – I can see variables via the cloud API and can initiate an OTA update via the API, as well.

We’ve got a pile of people who are seeing the same bug on the cubetube forums, as well. Is there a way that we (or particle) can initiate an automatic OTA firmware update to 0.4.3 for our users, so the photons correctly list as online? As a second-best option, is there a way that I can put up a “click to update your firmware” button on our site, to initiate an OTA update?

Thanks,
Alex

1 Like

Hi @enjrolas,

I’m hoping to release the photon auto-update support this week, which will send the new system modules when an application is flashed from the IDE, but you could also just OTA those system modules directly. Can you PM me a device id or two experiencing this issue and I’ll look into it ASAP.

Thanks,
David

Hey @Dave

I am also having a similar problem. My photon can be flashed most of the time, but it always shows up as offline on the Particle app. I am not sure how to fix this. I could send you my device ID as well if that would help?

Hi @Leon,

Sure please do! :slight_smile:

Thanks,
David

Hi All,

I think I’ve identified an issue that might have been causing what people were seeing in this thread. Can you please try restarting your photons and seeing if that helps now?

I wrote up a post-mortem about this issue here, please ping me with any questions / comments / concerns.

http://status.particle.io/incidents/qc1nr1vr2xq4

Thanks!
David

@Dave I just powered up my Photon that had been reporting as offline when it was in fact, online. It now shows up as online.

1 Like

I had this issue today. The Particle app was showing my Photon offline but the Photon itself was breathing cyan.

Is there anyway I can check the status of the Photon without issuing any command I.e. just want to make sure it’s online before I proceed with any operations.