[Old Spark core] Unable to setup device

I’m attempting to connect my Spark Core to wifi, but so far I’m not getting anywhere. My Core is plugged into my computer’s USB, and it’s flashing blue (waiting for credentials?). I’ve tried:

  1. Connecting using the Spark Core Android app on a cell phone & tablet. Both are connected to a 2.4G wifi AP, but neither can find the Core. The AP is WPA2 secured.

  2. Attempted to connect via USB. Using “particle --version” shows 1.5.11. The command line app can fine the Spark Core (COM5). When I try to connect it to the wifi AP, it finds the AP, and if I manually set security to WPA2, it will then ask for a password. When I supply the password, it errors out with “something went wrong Serial prompt timed out - Please try restarting your device” Potentially unhandled rejection [2] & [4].

  3. If I try to have the command line app auto-detect security, it fails as well.

  4. Does a Wifi password with an “@” in it potentially cause this?

  5. Spark LED is now solid blue.

This is an old Spark, I think one of the very first versions? Could that be an issue?

1 Like

I’ve also tried updating the Spark firmware, but I don’t get any improvement.

Edit: Apparently the first time I tried using an older firmware version. This one now works:


Just in case anyone else has this issue, these are the steps I followed:

  1. Put the Core into DFU mode.

  2. Install the DFU-Driver (Tutorial: Installing DFU-Driver on Windows [24 Feb 2015]). I didn’t add it to my Windows path

  3. Flash the firmware file

  4. Redo “particle setup”


your steps are not that correct and i’m not sure where you get the instructions from.

So for an old core,

  1. Install particle-cli

  2. Run particle flash --factory tinker

  3. Run particle flash --usb cc3000 (it will blink magenta and eventually revert to blinking yellow)

  4. Run particle flash --usb tinker

  5. Run particle serial wifi

Hope this helps for the people stumbling over this. Also changed your topic title to reflect the issue better!

1 Like

There weren’t any instructions on how to set up an old Spark Core. I just pieced it together by reading how to flash the firmware, and noting that other people had issues running older firmware on a Spark Core.

Glad to see there is an easier way!

So I found my 2nd original Spark Core - so I figured it’d be a great way to test out your steps. So far:

  1. Particle CLI has been installed.

  2. Running particle flash --usb factory tinker fails because a firmware file was not specified. So, I just did a factory reset.

  3. Running particle flash --usb cc3000 also fails, saying the device is not in DFU mode. Trying again with the device in DFU mode still fails, command line says it apparently can’t find a DFU device.

So, I’m still confused as to what exactly I’m supposed to do in order to get an older Spark Core up and running. If my old steps aren’t correct, but I can’t get yours to work either… what’s the next step?

Some progress, if I first install the DFU drivers & utilities. Running the command particle flash --usb factory tinker still fails, complaining about specifying a firmware file. However, I can get your steps 3 & 4 to work. But, the wifi setup fails, saying “serial prompt timed out, try restarting”. However, restarts don’t work.


The old steps I used to flash the updated firmware:

  1. Backup the old firmware:

    dfu-util -d 1d50:607f -a 1 -s 0x00020000:0x00022000 -U backup_frfirmware.bin

  2. Now flash the latest firmware (linked above):

    dfu-util -d 1d50:607f -a 1 -s 0x00020000:leave -D core-firmware.bin

Im not sure where you get those instructions for flashing ao you probably erased some other stuff in that memory space.

Also posting in multiple threads for the same issue makes supporting harder

Those are your instructions! :smile:

See this thread: Tutorial: Upgrading Factory Reset Firmware

Why would that erase other stuff in memory? I’m confused… following the instructions you’ve posted here don’t work. Following the process I’ve posted here does work (flash new firmware, redo particle setup). I’d like to put down a proper set of instructions in case anyone else is in my shoes with an older core. Spark Core is a great product, but not if people can’t figure out how to use it!

So, I’d politely request that if there’s a better way to set up an old core, those instructions be posted here. If my instructions aren’t acceptable (not sure why they aren’t, I’ve pulled all the info from Particle/Spark sources & this board), then list steps that do work.

You are trying to fix an issue where the core doesn’t connect to a Wifi network right? That does not warrant a factory firmware swap. The instructions you posted will not help another user fix the issue as well :wink:

I have them documented here as a pinned topic: [Spark core] Common issues

No, the issue isn’t connecting to a wifi network, the problem is with an old Spark Core the Particle CLI Setup fails, it spits a bunch of errors to the command line. So, the failure is before the wifi setup section even begins. The only way I’ve been able to get my old Cores to function is by updating the firmware, then redoing Particle Setup.

My question still stands… if none of the other instructions posted, other than my own, are able to get my older Spark Cores functional, then why aren’t they valid?

If there are other instructions that people should follow in my shoes, what are they? I’m trying to put down steps for the next person. I spent half a day tearing my hair out since none of the documentation helped. Finally pieced it together, but now I’m told that what I did was wrong? The steps you posted don’t work either… so what’s the next person in my shoes supposed to do?

EDIT: Those steps you documented in that pinned topic did not work for me. Tried those yesterday with another raw Core (the 2nd I received from the Kickstarter campaign). The steps 100% did not work. My steps here did.

The steps you posted ([Old Spark core] Unable to setup device) performs a factory firmware upgrade and the equivalent CLI command is particle flash --factory tinker

What i posted in ([Spark core] Common issues) contains steps to update an old core as well. I guess the confusion really comes from the typo in the commands i posted. :smiley:

I will let @christine, @peekay123, @Moors7 decide what’s the best here and step aside.

1 Like

Ah, that would make sense. Syntax matters :smile:

I would agree that command is safer that a straight DFU flash.

@kennethlimcp, I believe your approach is solid minus the syntax error :stuck_out_tongue_winking_eye:

I’m having a similar problem with setting up my v1.0 spark core. I’ve attempted your steps from the other thread without success. I get all the way to getting a breathing cyan LED but the core cannot be claimed to my account. It’s been previously claimed and I believe I’ve released it.

I’m on OSX, with particle-cli v1.8.3. Here’s a dump of my console-based attempts…

I’m not really sure where to go from here.

When I enter that deviceID in the web IDE, it indicates that it has been claimed already. Could you do a particle list to see if it’s not in there?
If not, could you try entering the deviceID in the Web IDE, and request a transfer of ownership. Perhaps you’ve used it with a different account, which will then receive an email.

I get the silly “add ?transfer_request=true to the URL” message without any indication on how to actually request the transfer. A search through the forums suggests many had to email support to get it transferred. Please provide steps or link?

I also attempted a list which was in the console dump and showed no devices.

The best way is to use the Web IDE and add the device which will allow you to request a transfership

What am I missing here? I am logged into the dev IDE successfully, if that matters at all.