Oddity with blue LED and demo script [SOLVED]

My core gets to the ‘breathing blue’ stage, but when I use Tinker (iOS) to set D7 high, the small blue LED doesn’t respond. However, if I use the web build app to install the example, it flashes as it should, except that after about 30 minutes it stops. Seems odd.

@pauldlynch re: your first issue, what’s probably happening is that you’ve installed other firmware on the Core, so “Tinker” doesn’t work anymore. You can ‘Re-flash Tinker’ in the app; in the iPhone app it’s in the menu on the left, and in the Android app it’s in the menu on the right.

As for your second comment, this is a known issue that we’re working on:

I can’t find any such option in the iPhone Tinker app.

Open the menu on the left, and click the arrow next to your Spark Core; it will open a submenu which includes the button you’re looking for.

2 Likes

Thanks.

I can explain why I couldn’t find it: the usual iOS UI would have a tap anywhere in the table cell having the same action as tapping on the button at the end. I had tried that, and noticed that it didn’t have any effect :-). It’s not unusual for a cell tap to have two effects, but when there is just one action, a tap anywhere would trigger it.

Anyway, following the reflash, D7 still doesn’t light the blue LED (main LED is still breathing cyan).

And further clarification:

I discovered that you have to do more than just set D7 to digitalWrite; you then also have to tap on the D7 button. That wasn’t clear to me, for some reason.

Hello @pauldlynch
Were you able to get the D7 blue LED to work?

Yes; it works both in the Blinky web app script; and also via Tinker. The solution was to understand that you need to set the D7 port to digitalWrite AND ALSO tap the D7 button in the Tinker app to set it high (or low).

1 Like

Thanks! @pauldlynch
Maybe the instructions could have been more intuitive. We’ll make a note of it.

@BDub Thanks for the info graphics! I’ll propose including these instructions in the documentation.

2 Likes