Not connecting to Networks [Solved]

Where I work there are several enterprise networks which all result in flashing green light when I attempt to set up the spark core via the command line. After reading that the spark does not play well with enterprise networks I switched over to use the local lab wifi which is specifically for projects like these. However I still get the green light. I then went to this github page to download the latest cc3000 patch. It however failed on install due to an error - “error during download get_status”. However the light did then turn magenta and flash, then go solid as the guide indicated was normal. The core still blinks green however even when connecting to the non-enterprise network. Any help would be fantastic.

Thanks in advance,

Rafe Lepre

UPDATE: Almost always flashing green now despite best effort

This is an issue with DFU-util but you can ignore it for now.

The preferred patch to use is termed as “deep_update”. You can download the file from here and flash via DFU-util: https://github.com/spark/spark-cli/raw/master/js/binaries/deep_update_2014_06.bin

IF you have spark cli, the command will simply be spark flash --usb deep_update_2014_06 and you do not have to download the binary file.

Otherwise, the DFU-util command will be:

dfu-util -d 1d50:607f -a 0 -s 0x08005000:leave -D deep_update_2014_06.bin

For more information, the docs for deep_update: http://docs.spark.io/troubleshooting/#deep-update-overview

It should work well after this! :smiley:

Thank you for taking the time to respond however this has pretty much had no effect unfortunately. Still unable to connect to any networks. Starting to think its not user error anymore.

@Hyphn,

I’m confident that it is configuration related.

Things like:

1.) 2.4Ghz vs 5.0GHz network

2.) SSID and password naming

3.) Security type etc…

I would recommend to check this flowchart and let us know which are you stuck at:

[1] CC3000 Patch via DFU-util (windows): https://community.spark.io/t/howto-update-cc3000-via-dfu-util/5665

[2] Spark-CLI on Windows: https://community.spark.io/t/tutorial-spark-cli-on-windows-05-july-2014/3112

I would like to again thank you for you help,

I am stuck at (3) I took the spark core home from work with me this weekend, to test on my home network, had a similar results despite using the new patching technique you told me about, again it would flash yellow then solid blue for about 1s until it switched to flashing green.

I have been forced to switch back to a (now perceived as) bulky arduino and wifi shield for a product demonstration tomorrow but I would love to get this working ASAP, again thank you so much for your assistance.

So you flashed the deep_update binary? What LED status did you see after flashing the binary? Did you see blinking orange?

Can you tell us your network configuration?

Alternatively, if you have an Android phone, try creating a hotspot and see if it works well.

Remember to send the Wifi Credentials to your core before creating the hotspot on your phone. (Blinking blue --> send Wifi Credentials)

Also, i will set the security type for the Hotspot to be Open just for testing :smiley:

After I flashed the deep_update it was solid blue then blinking green,

WPA2 is the security and its a running through an otherwise fully functional apple router

I have been using the terminal command line tool spark cli to set the wifi credentials as well as trying the optional tool, I can’t remember the name but it was a tool suggested on spark.io

I don’t have an android phone ): and I also don’t have the ability to set my wifi to open/no security.

@Hyphn,

can you take a look at your apple router and make sure that the 5.0 GHz option is not ticked?

It sounds like the deep_update patch did not work for you. Can you download this and flash:

https://github.com/spark/spark-cli/raw/master/js/binaries/cc3000-patch-programmer.bin

dfu-util -d 1d50:607f -a 0 -s 0x08005000:leave -D cc3000-patch-programmer.bin

After the download is completed, do the following:

Press the MODE button(> 1sec) to start the patching process. A Magenta color LED should blink every 200ms to indicate the patching is in progress. When successfully completed, the Magenta LED should stop blinking and stay ON.

To reboot back into the Spark Core standard firmware, hold the MODE button for 10 seconds while the Core is powering up (as above, to get into bootloader mode). This will activate a factory reset; if it is successful, the LED will flash white, and then the Core will return to its previous state (but with new firmware on the CC3000).
2 Likes

I wish I came back to this post sooner just tried this and it worked! Thank you for all your help! Best of luck

2 Likes