Not able to apply Patch

hello everyone, Hope you’re having fun with the Spark core,

But Actually I’m having a problem, I’m not able to apply the patch to my core, As given in the, I’ve downloaded the repositories and installed dfu-util also.

After that it was said to download the, since the one on the Github website was an old one, So I did and whenever I’m running the below statement
"dfu-util -d 1d50:607f -a 0 -s 0x08005000:leave -D deep_update_2014_06.bin"

I’m getting this output

Copyright 2005-2008 Weston Schmidt, Harald Welte and OpenMoko Inc.
Copyright 2010-2012 Tormod Volden and Stefan Schmidt
This program is Free Software and has ABSOLUTELY NO WARRANTY
Please report bugs to

Filter on vendor = 0x1d50 product = 0x607f
Opening DFU capable USB device… ID 1d50:607f
Run-time device DFU version 011a
Found DFU: [1d50:607f] devnum=0, cfg=1, intf=0, alt=0, name="@Internal Flash /0x08000000/20001Ka,108001Kg"
Claiming USB DFU Interface…
Setting Alternate Setting #0
Determining device status: state = dfuERROR, status = 10
dfuERROR, clearing status
Determining device status: state = dfuIDLE, status = 0
dfuIDLE, continuing
DFU mode device DFU version 011a
Device returned transfer size 1024
No valid DFU suffix signature
Warning: File has no DFU suffix
DfuSe interface name: "Internal Flash "
Downloading to address = 0x08005000, size = 110592

File downloaded successfully
Transitioning to dfuMANIFEST state
Error during download get_status

And after that it starts flashing green and when I actually press the mode button, it flashes solid blue, but I’m not getting the magenta colour which actually indicates the transfer of patch.

Help me out at the earliest,

Thanks in advance

I could be wrong on this, but I think the magenta color is only when you are downloading the patch OTA (over-the-air). If you are patching locally, you are writing directly to the flash.

You can check out the Verify the deep update worked documentation to, well, verify if the deep update patch worked or not.

1 Like

This the Output I got

“id”: “48^^^^^^^^^^^^^^^^^^^^^^”,
“name”: “EEC172_Core01”,
“last_app”: null,
“last_heard”: null,
“requires_deep_update”: true,
“connected”: false

It’s showing Not Connected, What should I do? My core is powered on