"No such file or directory" Particle Desktop IDE

Hello Everyone,

I am using Particle Desktop IDE. I have added “Internet Button” Particle library but at compile time I get the following error:

I have tried other libraries also, but still get the same error. Even “project.properties” also show the library is added. However, it is working if I “COPY” the library to the current project. But when I “ADD” it, it doesn’t work.

Thank You,

P.S.: @ScruffR, If you could guide, please!

How does your include statement look and what system version areyou targeting with your project?

Hey @ScruffR,
This is how my code looks:

And I’m using Particle Dev version 1.18.0 and right now I’m only compiling it, not targeting to any device!

Thank You.

That’s probably the issue. The modern libraries v2.0 need to be used in projects for 0.5.3 or higher.


I selected the target device(photon) with version 0.6.2 and still get this issue!
I’m feeling suspicious that it could be because of OS! I’m using it on Windows 10(64-bit version) and Desktop IDE is of 32-bit.
Can this be the problem?
If this is the issue, it’s my bad!:sweat_smile:

If it helps I have also seen a library (the google locator one) stop my project compiling in Dev since the latest release (CLI compile works).
The install also went wrong in different ways on the 2 systems I installed it on. On one it broke the “Open With” entry on directories and on the other it put %20 in the place of spaces in some of its filenames - which was easy enough to fix as it was a known bug on the Atom bug list.

@Viscacha, I guess the issue is different in my case!! It’s not working for any library!

I think the problem is related to to the following topic: Atom Projects / Library References / Not working as before?

I’m having the same problem since Atom suddenly updated itself. Afterwards some error messages were shown and references to particle libraries are no longer working. Only local libraries are working now.

OK then, glad to know it’s not just me with consternation… :upside_down:

I have enough “moving parts” to deal with in my project work, so when my toolchain throws problems diverting my attention from issues I should really be focused on, it’s more than annoying.

I’ve not seen anything posted by the Particle team either on this specific issue (albeit one can work around fairly easily).

@Trekky & @jimini ,

The update of the atom was the issue. Now, it’s working for me perfectly as I’m using older version.
And yes, Particle Community should solve this issue! :smile:

@ScruffR, can you tag someone from Particle Team, so that they can solve this issue!


We can tag @rickkas7

Its the only library I use that way as I otherwise use customised local copies (or my own) for devices that don’t yet have one or don’t have features I want. e.g interrupts on the mcp23008.

This ATOM update now forces me to push large “local” copies of libraries that were otherwise already resident in the Particle ecosystem… thus, my builds used to be 20-30 seconds but now require 2 to 3 or more minutes since I’m now sending monster lib file contents to be built each time.

What’s the workaround for this silliness?
Anyone have a hint?

Thank you all for giving us this background about this issue! We’ve reproduced this bug and filed it on GitHub. You can follow its status there. We’ll fix it asap.

1 Like