No compile icons in Workbench project?

Hello. I just opened a project in VS Code by using File > Open Folder

There are now no compile/load icons showing in the upper right corner like usual.

However, if I create a new project, they do show up.

Also of note, in the existing older project now shows the following 3 errors when opening, and I also noticed there is no longer a drop-down for the device and the deviceOS selection.

It’s like VS Code doesn’t know this is a Particle Workbench project. But when I re-open a newly created test project, the new project opens the Welcome to Particle Workbench tab and icons appear as expected.

This older project was working fine for months.

Any suggestions?

Thank you.

Update:

I think I figured it out. I had 2 folders with the same name, one inside the other. When I opened the inner folder it worked.

I’m still not sure what is happening though. If I opened the wrong folder (the outer one), then why did the files show up in the file list on the left side?

Is there a specific config or ini file being read by Workbench? Just curious if something similar happens again.

Thanks!

VS Code is a multi platform tool - only when a valid project is opened VS Code can decide which platform you are targeting and hence which extensions need to be applied.

The “outer folder” does not hold a project. It only holds a folder which may or may not, however there might also be loads of other folders which also hold projects but maybe targeted at different platforms.
Instead of assuming that - due to the absence of others - that single sub-folder would hold a valid project, VS Code just leaves it up to the user to acutally select the correct folder :wink:

What exactly does VS Code or Particle Workbench see that tells it what kind of project it is? Just curious what file is the important config, etc.

Thanks!

The contents of the .vscode folder inside the actual project folder would be worth a look