No Cellular on Boron

cellular
boron
Tags: #<Tag:0x00007fe2203a0340> #<Tag:0x00007fe2203a00c0>

#1

I have a Boron that seems as if the cellular radio just up and died. It just flashes green. I have tried everything imaginable to get it to reconnect to the cloud but no luck. It will not go into Safe Mode. I can get it into Setup mode and go thru the setup process. At the point it reaches Connecting to the Cloud it goes back to flashing green. I tried to get it into DFU mode but it won’t go into that mode either.

Any ideas? I sent an email to support with all the device info but I know they are backlogged so posting here to see if anyone else has run into this. I have great cellular coverage where I am with other devices connecting to the cloud just fine.


#2

You won’t be able to get into safe mode because that requires a cloud connection, and you can’t get past blinking green (connecting to cellular) so that is to be expected.

Assuming that the Boron is in account with the same email as your community forum account, the SIM is still activated both in our database and the mobile carrier, and should be working. You haven’t hit a data limit, for example.

In that case, getting a cloud debug log is the best way to see what error you’re actually getting while connecting to cellular.


#3

@rickkas: Thanks for responding. This boron is actually registered under a different email address - tech(at)odiconsulting.com

It looks like the device will need to be put in DFU mode to flash the bin file to it for debugging. One of the other problems is that it will not go into DFU mode either nor factory reset.


#4

Can you post a video of how you try entering DFU Mode?
You can also try activating DFU Mode via particle usb dfu (providing your device OS is up-to-date) or via the magic baudrate 28800.


#5

There isn’t a Boron under the tech account, only an Electron. If the Boron SIM has been released or deactivated that could also cause endless blinking green. But the cloud debug log will be the best to figure out what’s going on.


#6

I removed it and deactivated the SIM in an attempt to try and set it up again and re-activate it. Which is maybe something I shouldn’t have done. :roll_eyes:


#7

@ScruffR:

Some how after many attempts I finally got it into DFU mode. I was able load the tinker-0.9.0-boon.bin and that was successful. Running dfu-utl -l found it so that is promising.

@rickkas7:

I think I need to get the internal SIM re-activated somehow on the carrier end. I know I shouldn’t have probably deactivated it.

I think I am going to pickup a JTAG programmer just to have t if ever needed. I have a new Boron on the way if it turns out this one is bricked.


#8

UPDATE:

@rickkas7:

I was able to get it back into DFU mode again and flash the codedebug bin and messed with that for a while. I tried to run some of the advanced tests an connect over serial using Putty. It would connect with Putty but never display any output. It’s strange why it would take 5 or 6 attempts to get in DFU mode but finally gets there. I then followed the step to remove the codedebug and re-flash with: system-part1-0.9.0-boron.bin, then went thru the setup and it finally connected to the cloud! Yeah!!!

I don’t know what [or who?] fixed it. If anyone did anything on the backend then I owe you one! Interestingly, the device name is still the same so after all of this it retained its name.

Anyhow, what a learning experience! I know a lot more now than I did a few days ago.

Thanks @rickkas7 and @ScruffR for the help!


#9

That’s because the name is actually stored in the cloud (for that particular device ID connected to your account).


#10

This sounds very similar to a situation I had. I was able to setup the device but only after many attempts, resets, and flashing different firmware builds. It would never connect reliably and eventually would not connect at all. Trying to go through setup again always failed. Particle tech support eventually decided it should be replaced.
I’ve played with it some more while waiting for a replacement and see that no modem or SIM information is detected making me think that part has failed.
I’m noting this here just to point out that an intermittent hardware failure is possible.


#11

I found using the 9.0 build with the Boron LTE that after flashing 9.0 part1 that I could only flash the user code once, but it wouldn’t survive a power cycle or another flash of user code either OTA or in dfu mode. Doing any of those after the first user flash after 9.0 part1 resulted in constant blinking green. I always had to hold mode until it was fast blinking blue and reinstall 9.0 part1 and then flash user code. But don’t power it down or try to flash any other code again. Each time you need to flash new user code I had to start over with 9.0 part 1. I found this problem went away by downgrading the build to 8.27


#12

@Slimfetz

Thank for the heads up on that. So far I have been able to reflash several times with no problem. If run into the same issue I will downgrade as well.


#13

Good point. That makes sense. @ScruffR


#14

@trpropst

It is entirely possible. I had a few photons that were DOA once. However I have never had one fail on me so it seemed odd. Particles quality control is quite good. I thought mine died for sure but eventually got it going. Bad firmware will definitely throw you for a loop. :wink: It did to me.


#15

I’m also using 3rd party Sims. Not sure if that makes any difference regarding the firmware from 9.0 and the 8.27


#16

new to particle, but having the same issue. I had one of my borons working with a 3rd party sim, no issues. unplugged it for 4 days, and reconnected it and it wont connect (green light flashing). I have now done everything I can find resetting firmware, removing and reinstalling code for particle SIM, tons of stuff and finally got it back to green blinking.

I have checked data usage, and secondary antenna, and “outside”. I even once got a cellular system code (clouddebug) to work showing logs of the cellular attempting to connect, of course it was mostly gibberish to me.

if anyone has any idea of something I can check to see if it has become a hardware issue, please let me know,. Thanks!

starting tests...
turning cellular on...
deviceID=XXXXXXXXXXXXXXXXXXXX
manufacturer=u-blox
model=SARA-R410M-02B
firmware version=L0.0.00.00.05.06 [Feb 03 2018 13:00:41]
ordering code=SARA-R410M-02B
IMEI=XXXXXXXXXXXXXXX
IMSI=u-blox
ICCID=XXXXXXXXXXXXXXX
0000024852 [app] INFO: enabling trace logging
0000024853 [ncp.at] TRACE: > AT+CGDCONT?
0000024901 [ncp.at] TRACE: < +CGDCONT: 1,"IP","10569.mcs","0.0.0.0",0,0,0,0
0000024902 [ncp.at] TRACE: < +CGDCONT: 2,"IPV4V6","VZWADMIN","0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0",0,0,0,0
0000024904 [ncp.at] TRACE: < +CGDCONT: 3,"IPV4V6","vzwinternet","0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0",0,0,0,0
0000024906 [ncp.at] TRACE: < +CGDCONT: 6,"IPV4V6","VZWCLASS6","0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0",0,0,0,0
0000024907 [ncp.at] TRACE: < OK
0000024908 [ncp.at] TRACE: > AT+CSQ
0000024951 [ncp.at] TRACE: < +CSQ: 99,99
0000024952 [ncp.at] TRACE: < OK
attempting to connect to the cellular network...
0000024955 [system.nm] INFO: State changed: IFACE_DOWN -> IFACE_REQUEST_UP
0000024955 [system.nm] INFO: State changed: IFACE_DOWN -> IFACE_REQUEST_UP
0000024957 [hal] TRACE: PPP netif -> 8
0000024958 [net.ifapi] INFO: Netif pp3 state UP
0000024958 [net.ifapi] INFO: Netif pp3 state UP
0000024960 [hal] TRACE: PPP thread event LOWER_DOWN
0000024961 [hal] TRACE: PPP thread event ADM_DOWN
0000024961 [hal] TRACE: PPP thread event ADM_UP
0000024963 [hal] TRACE: State NONE -> READY
0000024965 [ncp.at] TRACE: > AT+CIMI
0000024967 [system.nm] INFO: State changed: IFACE_REQUEST_UP -> IFACE_UP
0000024967 [system.nm] INFO: State changed: IFACE_REQUEST_UP -> IFACE_UP
0000025001 [ncp.at] TRACE: < 310410152901110
0000025002 [ncp.at] TRACE: < OK
0000025003 [ncp.at] TRACE: > AT+CGDCONT=1,"IP","10569.mcs"
0000025051 [ncp.at] TRACE: < OK
0000025052 [ncp.at] TRACE: > AT+CEREG=2
0000025101 [ncp.at] TRACE: < OK
0000025102 [hal] TRACE: NCP connection state changed: 1
0000025102 [net.pppncp] TRACE: NCP event 2
0000025103 [net.pppncp] TRACE: State changed event: 1
0000025104 [ncp.at] TRACE: > AT+COPS=0,2
0000025105 [hal] TRACE: PPP thread event LOWER_DOWN
0000025151 [ncp.at] TRACE: < OK
0000025152 [ncp.at] TRACE: > AT+CEREG?
0000025153 [ncp.at] TRACE: < +CEREG: 2
0000025201 [ncp.at] TRACE: < +CEREG: 2,2
0000025202 [ncp.at] TRACE: < OK
0000026202 [ncp.at] TRACE: < +CEREG: 3
0000040202 [ncp.at] TRACE: > AT+CEREG?
0000040251 [ncp.at] TRACE: < +CEREG: 2,3
0000040252 [ncp.at] TRACE: < OK
0000055252 [ncp.at] TRACE: > AT+CEREG?
0000055301 [ncp.at] TRACE: < +CEREG: 2,3
0000055302 [ncp.at] TRACE: < OK
0000060942 [sys.power] TRACE: re-enabling charging
0000060984 [sys.power] TRACE: Battery state UNKNOWN -> CHARGED
0000062065 [sys.power] TRACE: Battery state CHARGED -> DISCONNECTED
0000070302 [ncp.at] TRACE: > AT+CEREG?