New User Experience

Coming from Arduino IDE and several ESP8266 boards I decided to give particle photon a shot…

The experience so far has been a nightmare.

First of all the Getting Started guide is missing information, the auto installer does not correctly set the paths so when you type> particle setup you get a missing file error. This has happened on 2 different machines.

You should mention the default install path or have in the instruction the full path to particle.exe (which is C:\Users[User]\AppData\Local\particle\bin)

On top of that the first time I was setting it up and Registering with the WebIDE it would not register until I logged out and logged back in.

Secondly, I have changed location and am having difficulty configuring Photon to connect to a new router.

I am trying to configure over USB but particle app locks up on either ‘Scanning for wild photons to appear’ or Configuring WiFI on COM4

I mean this is 2017, why force your uses to use a command line tool? Most of us are idiots or lazy and prefer to click on things. Whats the excuse? At least install a shortcut.

I would not recommend this device to anybody getting started with IoT, the wireless workflow is nice, but the configuration, registering is atrocious and needs work and I feel bad for all the newcomers getting their blood boiling

/rant

Edit: Solved my problem by plugging in a NETGEAR WiFI dongle and using ‘particle serial wifi’

2 Likes

This is the 4th time I am going to share the following today:

# EASY setup with particle-cli
# Put photon into listening mode
particle serial identify # Obtain deviceID
particle serial wifi # Connect photon to wifi
particle device add your_deviceID # Claim photon

And to add my two cents, you should avoid the web IDE whenever possible, and Windows is not a good platform for developing with Particle.[quote=“tocaedit, post:1, topic:30757”]
I mean this is 2017, why force your uses to use a command line tool? Most of us are idiots or lazy and prefer to click on things. Whats the excuse? At least install a shortcut.
[/quote]

Well you aren’t forced to used the command line, but in most cases it is most effective way of doing something.[quote=“tocaedit, post:1, topic:30757”]
I would not recommend this device to anybody getting started with IoT, the wireless workflow is nice, but the configuration, registering is atrocious and needs work and I feel bad for all the newcomers getting their blood boiling.
[/quote]

Every development platform has a learning curve, just be thankful that Particle isn’t too steep and the community actually cares about providing help.

That’s up to taste, I’d say :point_up: and for my own part I’d even contradict :sunglasses:

2 Likes

Not to start an OS war, but I get to enjoy using a package manager, a real kernel, native bash and no Windows malarkey.

To end the ‘war’ before it starts: windows has, so far, done everything I needed it to do in regards to developing on Particle. Everything else is a personal preference that I won’t even begin to argue about, but as far as Particle is concerned, Windows is more than enough. That’s mostly made possible by the openness of the various tools (Web IDE, open source Local IDE, open source CLI, etc…), so I’d credit Particle for that as well.

1 Like

Yes, Particle has done a wonderful job creating tools that will work on Windows despite the numerous flaws that Windows has.

Everyone does have their own workflow that they are comfortable with.

(Not to be statistical, but most of the people having problems on the forum are having the problem because of Windows being Windows. Incoming replies about Windows being more popular and there are more problems because there are more users.)

Thanks… I’m trying the Windows Desktop IDE now and I am still perplexed. I will get there eventually.

The WebIDE you cannot modify the library.

So my logic is the DesktopIDE will allow me to import and edit libraries but it seems a lot more manual than that.

What IDE do you guys prefer?

The struggle continues…

I use Atom, which is what Particle Dev is based on, extensively. For actually interacting with my devices I stick with particle-cli, and for building I use po-util, my personal solution to local particle development, which I’ve only developed for macOS and Linux currently (due to limitations with Windows).

I’ve developed po-util to work smoothly alongside Atom with keyboard shortcuts and a per-project configuration system that works well with my preferred workflow.

Hello!

I am glad that you were able to solve your issue, but wanted to reach out to you about your initial experience not being the best and wanted to apologize for that. We always welcome feedback and I appreciated your detailed explanation.

I know the Elites and our Engineers recommend using Build, the mobile app and Dev over CLI to begin with. We also have several easy-to-use tools with GUIs that are great for first time users of our products!

If you run into any other problems feel free to post them again or tag me and we can see how we can help you!

Kyle

3 Likes

The DesktopIDE, keep finding some more bugs, practically unusable, too much too list.

My Libraries says it does not exist.

When you click USE on a library it just creates a empty new project.
If you click View Source, it adds the files and you can use them but they are in the wrong folder.

When you do finally get something to compile it just little piece of the error. The box cannot be expanded?

What a mess! I may try reinstalling but I am doubtful.

I got some stuff to compile with WebIDE… but now i am stuck here


Trying to use MPU6050 and SSD1306 OLED both on I2C which was easy to do on Arduino.

The thing with WebIDE is you cannot modify library when needed… adding it manually with the + tab works, but what a pain.

Probably just the libraries haven’t caught up with the new firmware builds?

The MPU6050 library example wont compile.

I don’t think this should be #warnings but #warning
But if you build against 0.6.0 the error goes away - 0.6.1 has got some compatibility glitches Particle is currently investigating.

That’s by design, merely viewing the sources should not clutter up your project.
If you want to add the library to your project press … Use, then you get an additional selection Add to current project or Copy to current project.
The latter is what you want if you desire to modify the library.
This will copy the library sources and if required all dependencies to your lib folder inside your project.

And I also can’t confirm this statement

For me … Use + Add to current project just adds the dependencies entry to the project.properties file (as expected).

2 Likes

First of all thank you for the quick reply.

The Use button does not work like that at all for me (no popup) but its not a big deal…

I have found that if i go to the GitHub pages for the libraries i need and download from there they compile against 0.6.1

Of course this means putting all the library .c/.h files in the same folder as the .ino file (no folders at all), which is strange but it works.

I believe they may be in the middle of a transition right now but once you learn the quirks it does work… cant wait to see when the kinks are worked out.

Thank you all again and enjoy.

2 Likes

My Use button acts the same as @tocaedit describes, this same new project menu also has an aversion to project names with spaces in.

What version Dev are you running on what OS?
Especially what version has your particle-dev-libraries package?
This is how my workflow for copying a lib to my project works.

BTW, despite it being possible, having blanks in file names often causes more troubles than it’s worth :wink:

1 Like

Dev 1.8 windows,10 and absolutely no idea

The package version you can find via File - Settings - Packages

0.2.18 it says

That’s odd - @suda, have you got an idea what’s wrong here?

It looks like both @tocaedit and @Viscacha are using Windows, maybe that’s the issue. Could one of you create an issue in particle-dev-libraries repo so we could allocate time to look into this?

@suda, I’m on Windows (8.1 Pro 64 - checking 10 now) too and for me it works as shown in my screenshots


Update:
Win 10 Pro 64 works just as well.