New User - Blue Breathing but no connection to phone

Just got my Spark Core. I installed the App on my Moto X Android 4.4, created an account, gave it the password to my router and the Core is now breathing blue. However, my phone will not connect to it. I get No Cores Found Try Again.

I have reset, tried again, powered off/on, etc. still no luck.

I saw another post for this issue and it referenced some instructions on github, but the link gives a 404 error.

Help? Thanks.

First things first, are you sure it’s a Particle Core, and not a Particle Photon? Make sure you’re using the correct app. If it’s indeed a Core, you could try a factory reset, and then try again. With a Photon, there are some other steps which we can take if it’s indeed a Photon.
When you say “breathing blue”, is it purely blue, or could it be Cyan? If it’s cyan, it means it’s connected to the cloud. At this point, you should figure out the device ID. You can do this with the Particle CLI, but a regular serial terminal should suffice as well. In both cases, place it in listening mode, by holding the setup/mode button until it starts blinking blue. Then, using the CLI do particle identify or connect to it and press i if you’re using a serial terminal (putty for example).
Go to the web IDE and open the devices tab, there, click “add new device”. Enter the device ID you got.
After that, the device should show up on your account.

It is a Spark Core - apparently they were superceded, but this is definitely a Spark Core - says so on the box and matches the picture on the site.

It is breathing cyan (I probably said breathing blue, sorry). I am able to work with it via the USB interface, download a small program from the cloud site and have it work. Also, via the CLI, I was able to get it’s hex ID.

I just can’t connect to it on the phone. Keeps saying No Cores Found and I can press Try Again to no avail. I’m using a Moto X, Android Kitkat, 4.4, on the same Wifi network and router that the Spark Core is on. And it must have talked to the Core originally, since it was able to communicate the Wifi password.

Ideas? Thanks.

So it seems the Core is working and the app is problematic. Could you try logging out of the app and log in again. It’s fairly easy to create a new account with incorrect credentials due to typos.