New Photon won't setup [SOLVED]

I got a new Photon and attempted to go through the setup process via the iOS app. This resulted in it not connecting to the wifi, so I moved to using the CLI setup process (OSX). This continued to have issues connecting to the wifi. I still had troubles, so I ran particle update on the device. Now, it is blinking blue (in listening mode) but when I attempt to run the iOS setup app, it errors during the first step “configuring wifi” and displays this message:

Uh oh!
Setup process couldn’t disconnect from the Particle device Wi-fi network. This is an internal problem with the device, so please try running setup again after resetting your Particle device and putting it back in blinking blue listening mode if needed.

Attempting via the CLI appear to configure the device, but then can’t find the device in the cloud. The LEDs on the device are blinking blue/green, and about once every 15 to 30 seconds it rapidly blinks red and yellow for about half a second, then goes back to blue/green again.

I have tried multiple wifi networks, both with security and open (unauthenticated). I can’t seem to get the device to connect. Any help would be appreciated.

My primary WiFi router is a Netgear 802.11a/b/n, and I’m using the 2.4GHz signal. I also attempted to use my iPhone’s wifi tethering.

I was able to resolve this issue using this post

1 Like