New core can't connect to cloud, only blink the yellow light

i just got a new core, I connect it to WIFI, however, after a few light-blue blinks, it then starts to fast blink yellow light, and then the red light. I have some other cores, never happened this before .

Could you try a factory reset?

I tried it, it didn’t work.

With the particle CLI, could you try particle flash --usb cc3000 when it’s in DFU (blinking yellow) mode?

I tried it just a minute ago, after that operation, the light color turned into magenta for a while, then blue, and last just blink the yellow led constantly.if i press the reset button, it still blinks yellow, and no matter how long i hold the mode button, it never goes into blue color mode. The only thing I could do is to do a factory reset, and still after all of these, it goes to cloud, blinking the yellow again and again.

Give particle flash --usb tinker a try?

I am afraid, it didn’t work as well, still the same behaviour

Could you check your power supply/cable? Those might be causing issues.

it is the new cable, which has successfully worked for other cores.