New core - can`t connect to build

I bought a new core. I connected it to my iphone but for some reason I cant connect it to the I tried to get my core id but coolTerm wont show me the id number (I have mac).
Any help?

Did you used the same account credentials in the iPhone app and the build environment?
You can try to install the spark cli, login there, and find out the device ID.

To obtain the core_id via a Serial Terminal,

Place the core in Listening Mode (blinking blue) and set the baud rate to 9600.

Hit I on the keyboard and you should see the core id displayed. :slight_smile:

where to set it? Serial Terminal? please be more specific…
I tried to install spark cli but it didn`t exactly work.

It seems to me that you are kind of new to Serial Terminal?

Those are really basic settings…

1.) Plug the core to your laptop

2.) Press the MODE button for 4 seconds until the core starts blinking blue

3.) Launch Coolterm and click on “Options”

4.) Select under the list of devices and look for “usbmodem…”

5.) Hit the connect button before keying i on the keyboard.

I hope that is clear enough to follow? It’s also covered in the documentation…

Hi @omrigotlieb,

There’s also a guide for that here: