Mesh: issue with certain? Xfinity routers

Interesting. I heard internally that it was a DNS thing.

It might be, it’s just my semi-educated guess that DHCP might be at least involved :wink:

I’m almost certain it’s this. @rickkas7 linked me that in another thread, so I fired up wireshark and saw nd6 packets. When I killed the source of the nd6 packets, the problems stopped. In my case, the nd6 packets were being sent out by odhcpd running on an openwrt access point.

As far as I understand it: the nd6 packets contain wrong/bad DNS settings, and the mesh device blindly accepts it as fact & overwrites those that were obtained via ipv4 dhcp.


So, I guess I shouldn’t wait up for my Xenon to finish joining my network? Three (3) tries on each of three (3) different Xenons, similar results:

Quick flash green on the Xenon, breathing cyan on my Argon but I’ve also seen fast cyan on the Xenon with breathing cyan on my Argon.

Router = Xfinity Cisco DPC3939, phone Samsung-SM-G930A.

That’s interesting, when I was having the problem, my endpoint Xenon would always get past the adding Xenon to mesh network step, but would hang on Starting a secure session with the Particle cloud via Gateway step.

I have no idea what that tells us, but it looks different than my issue.


Try a non Samsung phone.

I used a iPad pro 11 to setup everything since my Samsung Note 9 was having issues during setup.

Thanks, @jimbol & @RWB. Unfortunately, we might not have the device here I’ll need to get this to work. I tried my wife’s iPhone 7 but no luck. I then tried to see if I could use my old Motorola Droid but that would only allow me to load Particle v2.2.2 instead of the current v2.3.5. I also tried my Samsung SM T377A tablet but the camera won’t focus on the tiny sticker. We’ve pulled out the iPad Air to see if that might work but we’re trying to get it updated first. I’m not holding out a lot of hope.

As a side note, I will say that the Particle instructions for the Apple are much clearer than for the Android. I know this is early on but I’m hoping the programmers at Particle are paying more attention than the people writing the tutorials. When I read things like this in the quickstart guide: “As such, when you go to compile source code, it’s a good idea to verify that the board you” What? The sentence just stops leaving the person hanging, much like my Xenon is leaving me hanging.

Well, my wife’s iPad Air (iOS12.1) at least gets me to the “starting a secure session with the Particle cloud via Gateway” but stops there. I’ve exhausted our resources; we have no more phones, iPads, or tablets to try. I guess I’ll wait for some patches to come out!

I’m not overly concerned as I have no real need for this stuff, I just purchased it for the learning experience. I will say, however, that it doesn’t seem to have been very well tested before launch. My Argon seems to be doing relatively well but even that is giving me the following warning on my console: “The device is disconnecting from the Particle Cloud too frequently. Large numbers of cloud disconnects are often caused by poor signal strength or network congestion. If possible, move the device to a place with better Cellular signal.” Assuming that’s a typo and they’re talking about WiFi, my Argon is sitting literally 24 inches (60 cm) above my router!

1 Like

Thanks (all) for notes about cases that are not working.

For what it’s worth (who’s keeping track?), I’ve got the Ubiquity “Amplifi” home router, using Comcast as ISP, and the initial (Spectra 2018 hardware kit) Xenon pair and Etherwing work well together. DHCP is issuing IPv4 locally. I don’t know if IPv6 is being issued…

1 Like

That is the same problem I am having. It connects to the wifi once during setup, then after about 30 seconds, it begins searching for the internet, never to connect again. I have an Xfinity router, also.

Please fix this soon!

1 Like

This problem also impacts ASUS RT-AC88U routers. The XENON will briefly flash cyan after the setup in sync with the Argon (gateway), and then suddenly change to flashing green fast. The workaround is to disable IPV6 in the ASUS router and then setup the XENON devices again.

This is fixed in 0.8.0-rc.26 which should be released in the next day or two.


I hit this issue too. When will 0.8.0-rc.26 be released? I am looking forward to it very much.

1 Like

We are still testing rc.26 – a regression was found which has to be addressed. Keep an eye on the issues/fixes thread for updates.

Hey folks – wanted to follow up here to let everyone know that v080-rc.26 has been released and should address Argon and Xenon connectivity issues with certain IPv6 enabled networks.

Instructions for upgrading are available here – would love to hear your feedback on the update and whether or not it resolves your connectivity issues:

I applied rc.26 to my devices, and now it stars connecting through my Xfinity router after some struggle with reconfiguring the network. Thanks!


I am so glad to hear that! Apologies that this fix wasn’t already discovered before you received the hardware! Please let us know if there’s any other issues you experience that we can help with. Our team is standing by and eager to help.


Yay! I was able to get all three (3) of my Xenon’s connected with 0.8.0-rc.26. One Xenon was a little stubborn but I did a firmware reset and then it worked first time.

Router = Xfinity Cisco DPC3939, phone Samsung-SM-G930A.

Suggestion: someone at Particle might want to compare the iOS setup instructions to the Android. The iOS version is much clearer.

OMG. You Particle team rock! 0.8.0-rc.26 fixed my router’s woes (Xfinity Comcast X1). Argon updated. Xenon updated. I’m looking forward to my single, and first LTE Boron connection. So freaking excited. Seriously. The list of the things you fixed, of which I understand ~5%, is amazing! I LOVE THIS PLATFORM! Arduino on steroids. Time to flex the mesh muscle! I praise and proselytize (scrabble word!) you (Particle Photons and now the Mesh babies) so much to people that understand. KEEP UP THE GOOD WORK! Can you hear me?
Best regards,
old fart,
smell you later,
Odor Decoder