Maybe broken photon? [SOLVED]

Hey, I’ve purchased 2 Photons. One works great and I love it!
The other one behaves weird:
I was able to connect it to my wifi using the app, I am able to use tinker without any problems, but as soon as I flash code (I tried both build and dev), weird stuff happens. Sometimes it breathes cyan, then it flashes green like its lost the connection to the wifi. Sometimes it flashes two times red, after that it is magenta…
I tried to reset it, used diffrent wifis, diffrent power sources…

No idea what i should do now?
Maybe the hardware is broken?

Best regards

Have you read this thread?

I guess when you flashed your new code, you triggered a firmware update that will take its time, and if you got impatient (not knowing of this), you might have interrupted the update causing yourself some trouble.
But relax, this usually can be fixed.

One thing you should definetly do is to put your Photon in Safe Mode an flash a very basic program like “blink a led” and let it finish its firmware update.

If this doesn’t work anymore since you’ve upset the device too much, you might need CLI and dfu-util to get things sorted again.
Not a big deal, and useful to have these tools anyhow.


CLI got rid of my problems - thank you very much! :slight_smile:

1 Like