Mac OS sleep issues possibly?


#1

Hi everyone

This has been flagged to support but it occurred to me that it’s a picnic problem as I’ve achieved this twice!

I coded a Xenon + sensor this morning and left it to run for 2 hours. All was well so edited and flashed again.

The code ceased to run but xenon was breathing fine. Tried to flash tinker but didn’t work. Tried CLI and flashed bin, seemed ok so attempted tinker which failed leaving red SOS (10flashes)

Could there be an issue with me not refreshing webIDE when I went back to edit/add code?

Thanks


#2

Is your question - did the flash actually happen?

When I have what I think might be issues like this I generally put the Xenon in dfu-util mode and plug in a USB cable and flash it. That way to ensure the flash has happened. Maybe you have got out of alignment with device OS and app/tinker? Best to start with system-part1, bootloader then tinker, if that connects then flash the app.

I have certainly not had an issue with Mac OS sleep whilst using Web IDE.


#3

Thanks I’ll give that a try.