Strange error - OTA flash of app to Xenon results in Tinker being loaded

I have a Xenon running on a featherwing board. It was running for few months, when it became unavailable. No worries, I’ll reboot it.

Then I decided to reflash it in order to get the latest Device OS (not sure which version was on there, but I’m going to the current “default” which is 0.9.0).

It appears that it is being refreshed with Tinker! I can’t get my simple app to OTA flash on to the Xenon.

The app itself does not have any libraries. I confirmed that it verifies fine. It has two Particle.functions, one Particle.variable, and one .publish event.

Has anyone seen this before?

I suppose my next step would be to do a DFU update, but that’s inconvenient…

Have you tried removing and reclaiming it?

I would suggest putting in DFU mode and flashing the device OS (0.9.0) then tinker via usb. Check it is working correctly as tinker app and then reload your application again.

When you are OTA flashing do you monitor the device in the console? It is quite possible the flash did not complete with success and diagnostic.

Thanks guys. I tried dfu flashing, but it didn’t recover the Xenon.

I ended up unclaiming and using the mode/reset button to get to the factory reset (

I went through the setup using the iPhone app and was back in business!


Getting into DFU mode is a bit hit and miss I have found - I am using a Xenon with the Ethernet wing and I have to unplug the ethernet cable first before DFU will ‘take’.

I have had to re-claim my device a number of times in the past 10days after an app code crash (SYSTEM_THREAD() enabled or not).