Login Failed: ECONNREFUSED 127.0.0.1:8080

The first time I logged in everything worked fine. Now I cannot login. Do I reformat the Proton?

What tool are you using?

I installed ParticleToolchainInstaller from github and followed the instructions from Toolchain for Windows Installer.

I am using Windows 10 with the USB connected to Photon. WiFi on my network is turned off. Is it required to use WiFi for first time installation? I do not have a smartphone.

Windows 10 Home version 1511
64-bit operating system, x64-based processor
Intel Core i5-4200U

If this makes a difference in the error messages.

When I type the command ‘particle serial wifi’ it replies ‘! serial: No devices available via serial’.

The Photon is blinking blue and is linked via USB to the computer in Windows 10.

Device Manager shows Photon with WiFi in Universal Serial Bus devices in Windows 10 Home version 1511.

You will need to turn on your Wifi card in order to configure the Photon.

Not sure why the serial method is not working for you though…

If you have your device on a USB 3.0 port try another (best 2.0)

And have you installed the Particle serial drivers already?

I formatted my computer and installed a new Windows 10. I found my error. In Step 4 in Windows 10 Full CLI and DFU Setup, I did not reset the Photon by clicking the reset button. This explains why the USB shows PhotonWiFi in Device Manager. Now it shows Photon DFU.

Connection established. It works. Photon is awesome!

1 Like

When I select the WiFi network to connect to the prompt displays nothing. Photon is flashing green.

What prompt?

I thought it worked :confused:

When I enter ‘particle serial wifi’ from Administrator Command Prompt (cmd command) in Windows 10 Home using a non-administrator account in Windows 10, the response is 'Should I scan for nearby Wi-Fi networks?, I select Yes. ‘Select the Wi-Fi network with which you wish to connect your device’, I select my WiFi network name. Afterwards nothing is showing in response from selecting my WiFi network name in the command prompt.

Should there be a syntax response after I select my WiFi network name on the terminal screen in Windows? The Photon continues to blink green.

At this time I’d say the Photon should be in Listening Mode - blinking blue not green.

As I’ve had issues with auto scanning the present networks I prefer to enter my data manually - try that?

I set the Photon in Listening Mode.

I entered the data manually. The blue light changed to flashing green. Now the light is flashing blue.

The response is ‘Done! Your device should now restart’.

Huh? Blue? Not cyan?

Could you try a different network - e.g. your phone AP?
We’ve seen issues with some Netgear routers, or combined 2.4/5GHz networks, but if your device does not get out of Listening Mode, it seems the network is not configured properly.

Could you shoot a video of the colors your Photon is going through while setting up.
Make sure to clear all credentials beforehand by holding SETUP 10+ sec till rapid blue flashing occures.