Issue Running Commands in Particle CLI Due to Spaces in User Name

Hi there
I'm encountering an issue when running commands in Particle CLI within Particle Workbench. The problem seems to be related to how Particle CLI interprets file paths when the user name contains spaces. The command I'm trying to execute looks like this:

make -f 'C:\Users\Doni del Toro.particle\toolchains\buildscripts\1.15.0\Makefile' compile-user -s

As you can see, the user name "Doni del Toro" contains spaces, and this seems to be causing Particle CLI to skip part of the path, resulting in the command not executing correctly.

I've tried wrapping the entire path, including the user name, in both single and double quotes, but the problem persists.

Has anyone faced a similar issue with Particle CLI or with development tools that don't handle user names with spaces correctly in Windows? Is there any solution or specific configuration I should modify to resolve this problem?

Any advice or assistance would be greatly appreciated. Thank you.

That's a limitation of the GNU make tool, which does not support paths with spaces, and never will.

When you do a local build with the CLI using one of the options in the command palette, it silently converts the path to a 8.3 path that does not contain spaces, then calls make using those paths.

If you want to use the make command directly, you'd need to do the same thing.

1 Like