[ISSUE] Prevent upgrading firmware to 0.7.0


#1

How can i keep my firmware at 0.6.3, even when i specify to use that ?

I created a new project in PW. I then copied my current projects source files into the new “src” folder.
I then set target platform to P1, and Firmware version to 0.6.3.
It compiled locally just fine, I then entered its ID using Set Target Device, and then selected "Cloud Flash"
it flashed it, and rebooted. so far all great success, until moments later i saw the led go magenta again, which told me it was upgrading the firmware. After i let this process finish when my device rebooted sure enough it put it to 0.7.0.


#2

I don’t think configurations are available for local builds of all system versions in the current alpha so I suspect it’s just defaulting to 0.7.0.


#3

Not sure about that, when I switched to 0.6.3 I got the download repo message.
Just make sure to save the workspace file after changing the target.

@rickkas7, if that wouldn’t be the case it would be good to get a notification just as you do get when trying to set the target to 0.6.2.

But for 0.6.3 @ p1 you get this

@seulater, does your workspace file look like this?

{
    "settings": {
        "extensions.ignoreRecommendations": true,
        "C_Cpp.default.configurationProvider": "particle.particle-vscode-core",
        "files.associations": {
            "*.ino": "cpp"
        },
        "particle.targetPlatform": "p1",
        "particle.firmwareVersion": "0.6.3"
    },
    "folders": [
        {
            "path": "."
        }
    ]
}

#4

It looks like 0.6.3 is present in the cloud. Maybe it didn’t load properly.

Also, it would be good to double check the firmware binary using particle binary inspect to see what version it targeted. It should be in the target directory.

Actually, deleting the target directory might be a good idea. It’s possible things weren’t rebuilt properly after switching system firmware versions as well.


#5

yes.

The building and uploading is correct for 0.6.3.
The issue is after I uploaded my code, it then upgraded it from 0.6.3 to 0.7.0.


#6

Have you done a particle binary inspect on the file you were flashing to the device - as Rick suggested?
Can you post the output?

If the application firmware is targeted at 0.6.3 and the device is currently featureing 0.6.3 Device OS there would be no reason for the Safe Mode Healer to kick in and upgrade the Device OS.


#7

@seulater thanks for the report.

Particle: Cloud Flash and Particle: Cloud Compile should respect the particle.firmwareVersion configuration setting - they currently do not.

work-around: run the Particle: Launch CLI command then particle cloud flash --help in the terminal that launches.