[ISSUE] Particle Workbench AppInstall on Linux (Ubuntu 18.04 LTS) Fails


#1

Particle Workbench [extension]

Error: Command failed: /usr/bin/snap --install-extension particle.particle-vscode-pack error: unknown flag `install-extension' at makeError (/tmp/.mount_ParticDOBHkD/resources/app.asar/node_modules/execa/index.js:174:9) at Promise.all.then.arr (/tmp/.mount_ParticDOBHkD/resources/app.asar/node_modules/execa/index.js:278:16) at process._tickCallback (internal/process/next_tick.js:68:7)

Please [report this error](https://community.particle.io/c/particle-workbench)

#2

ping @m_m


#3

Welcome to the community :wave:

Only a word of courtesy: While this is an official, digital forum for Particle the members here are still humans and as such we like to be addressed somewhat more personally than just dropping some arbitary error message on us without any further comment.

Maybe have another look at this thread
https://community.particle.io/t/welcome-using-particle-forums-and-forum-etiquette


#4

Lol, sorry @ScruffR. This was during the install process on my Ubuntu install. I had already installed Visual Code separately, but when I downloaded the packaged “AppInstall” and attempted to run it, this was the result. This is actually why I did a fresh install of Pop_OS on another NVMe drive that I had in my system. I wasn’t sure that my Ubuntu install was in a sane state anymore so it was just quicker / easier to start from scratch and build my way up from there.


#5

According to this other post, is your issue solved now?
Can we mark this thread as such?


#6

@Dygear thanks for reporting the issue, sorry for the bumps :pray:

as i think you’ve discovered, if you already have VSCode installed it’s sometimes easier to just use its native “install extension” UI to install Particle Workbench.

fwiw, the installer error you are hitting is a bit odd - under the hood we rely on apt to install VSCode itself. so if that’s not working properly or unavailable entirely, you’ll get errors. in this specific case, it seems which code is returning a different utility (perhaps due to this).

one thing i have on the list here is to support additional packaging tools - e.g. rpm and snap - sounds like you are snap user?


#7

@m_m I’m running Ubuntu on my other drive. I literally just installed Pop_OS! so I can check from a simple starting configuration should I run into the problem again and you could build up to the same point of failure.

I don’t use snap installs at all, but it seems the installer sees that snap is installed and starts to use that. I always use apt install for my package installs. (Call me old fashioned.) For the most part, probably because I don’t understand them, snaps dont ever seen to work for me, the 3 times I tried to use them in the past.

But I made no steps to tell the Workbench Installer to use snap.


@ScruffR while, yes I do have a working install of Particle Workbench (On my other OS), there seems to be an underlying state issue with the installer that should probably be handled in its code.