New to Particle....Visual Studio downloads but Workbench extension will not?

I am getting the following error (see pic) when trying to install workbench…I downloaded it but still cannot install it???

Hello,

Please download Git for Windows.

There are ~300 repositories… Do you have a link to point me to?

hi, not sure if this can help, but have you downloaded the workbench installer from here?

Please disregard if you did this already.
Thanks

Hello…
Yes I downloaded from that site. The top error above in my post “Unable to…” is from me trying to install it from the download.

The bottom error is me using the VS marketplace tab on the left and trying to install / run it…

It appears to me that the extension is NOT compatible with 1.26.1 VS???

NOT compatible with 1.26.1 VS???

the current version of VSCode is v1.65.1 (see here) version v1.26.1 is no longer supported. your best bet is to upgrade your VSCode instance - here’s how to do that:

Thank you! That worked…Someone needs to update the VS download on the particle site…I got it from there but not sure where on the site now.

you probably had an old copy previously installed and didn’t realize it (though let me know if you 100% know that you did not) - the Workbench installer checks for previous installs and skips installing VSCode itself if it finds one.

Not sure how I got there but I DEFINITELY started out on the Particle site. I am new to Visual Studio and Particle so I definitely wouldn’t have gone to VS without a push from Particle site.

I definitely did NOT have an old copy on my machine…as I use GNU C compilers on ARM and TI processors…never worked with a particle before…
Thanks for the help.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.