[ISSUE] no source file found for local compile


#1

fresh install of VSCode, no problems installing Particle extensions, local compile toolchain. In time honoured fashion, I’m trying a Hello World program. Created a new Particle project, which compiles via the cloud, but not locally.

The HelloWorld program IS in a Git repository, and I understand the fatal errors relating to git can be ignored: but for some reason the local compiler isn’t finding HelloWorld.ino. Any suggestions?

Supporting information

  • VSCode Version: Version 1.28.2 (1.28.2)
  • OS Version: Mac OS Mojave, Version 10.14
  • Other extensions installed: other than Particle, only PrintCode

Steps to Reproduce:

  1. Particle Create New Project
    2.Particle Compile application [local]

Launch with code --disable-extensions to check.
Does this issue occur when all extensions are disabled?: YES


#2

Same problem over here. Any answer?

Have tried moving sources to all logical folders.


#3

I have development folders on iCloud drive. The workspace is in an iCloud drive folder. I moved the folder to the local drive and then the build task worked.


#4

@sdcsdcsdc - thanks for the report. do you mind re-trying using the latest build? i suspect at the least you’ll get a more helpful error message.


#5

Same problem: no file found- tried with latest build, opened New Folder, created new Particle Project.

However, and props to steelydev that folder was in a Dropbox. When I create a new folder in a non-shared folder, compilation works.