Could not find task: Compile application (local)

I’m running Windows 10 with an install from ParticleWorkbenchInstaller.exe

I haven’t used Workbench for over a month, when I came back to it I can no longer compile locally.

I created a new project, opened the .ino file, installed compiler toolchain 1.5.0 for an Argon, configured the project for my device, and then tried to perform a local compile.

From: image

I get: image

I have uninstalled, power cycled and re-installed from a fresh download off the website. I can compile in CLI
image

Here is from the terminal:

PS C:\B\Particle_Programs\tester\workplease> particle compile argon

Compiling code for argon
Including:
src\workplease.ino
src\workplease.cpp
project.properties
attempting to compile firmware
downloading binary from: /v1/binaries/5e8ba6903cffc30001e34789
saving to: argon_firmware_1586210410410.bin
Memory use:
text data bss dec hex filename
4844 108 1020 5972 1754 /workspace/target/workspace.elf

Compile succeeded.
Saved firmware to: C:\B\Particle_Programs\tester\workplease\argon_firmware_1586210410410.bin
PS C:\B\Particle_Programs\tester\workplease>


Which is a cloud compile. But if I ask for Particle: Cloud Compile , I get:

When I open the developer tools console and run Particle: Compile application (local) I get:


The output of the error log is:


I only have the needed extensions installed:
image

What can I check/change to get the local compile pointed to the right location?

Ping @m_m

EDIT:
Does cleaning help?

Screenshot from 2020-04-06 21-32-42

1 Like

I’m not convinced that leading forward slash is supposed to be there
image

Can you share a screenshot of your entire (including status bar at the bottom) Workbench Window with the Explorer (image) open?

The clean task could not be found either.

How would I remove the slash at the front? Where can I edit where it looks fro certain tasks?

Can you glean anything fro this? Let me know anything that would be good to look at.

hey there :wave: sorry for the bumps :pray:

I haven’t used Workbench for over a month, when I came back to it I can no longer compile locally

i assume that means it was working at one point? if so, are you working with a project that you know once compiled fine?

have you updated VSCode recently? if not, give it a try:

looking at your screenshot above, i can tell Workbench is installed and running because you have our action buttons top-right as well as project settings displayed in the status bar.

try running Particle: Audit Environment as described here and share the non-sensitive bits in this thread.

beyond that, the only thing that caught my eye is the path /c:/B/Particle_Programs/tester/workplease - that seems wrong. is that project located on some sort of remote drive (e.g. dropbox, etc) or otherwise non-standard directory? if so, try creating a project in a standard directory.

the errors you are reporting are a bit odd in that you show “cannot find task” but then show the output from running that task so :man_shrugging:

2 Likes

Yes, I have had it working in the past. I’m not sure what I’ve changed since then.

I uninstalled VS Code, deleted the user data folders, and reinstalled from ParticleWorkbenchInstaller.

Now it works! It was the deleting of the %APPDATA%\Code and %USERPROFILE%\.vscode folders that did it.

Thanks for chirping in everybody.

3 Likes