[ISSUE] could not download gcc-arm from behind proxy


#1

I’m getting this error:
image

My PC is behind a company-controlled proxy and I always have issues downloading and installing new tools if they were not designed with this use case in mind.

This post has a similar error but I am unsure if they also have a proxy or if it’s unrelated:
https://community.particle.io/t/tutorial-installing-the-particle-workbench-developer-preview/44244/28?u=dillon1337

Supporting information

Steps to Reproduce:

  1. Try to install Workbench VSC extensions from behind a proxy.

Launch with code --disable-extensions to check.
Does this issue occur when all extensions are disabled?:

The extension does not appear when disabled so I cannot check if it works.


#2

Sorry to hear that, @Dillon1337! Can you try out the recommendations here?


#3

Unfortunately, those are’t helping. I tried --proxy-pac-url= and --proxy-server= even starting them from a administrator prompt.

I’m getting this message now (which I am guessing just means that it’s trying to download this file first instead of gcc-arm like before):
image

I can search for extensions in the Marketplace, so it seems as though Code can generally access the internet, just not the Particle extension specifically.


#4

Bummer. There’s an issue tracking Proxy support for extensions found here (feel free to +1 it!)

We’ll investigate any of the workarounds suggested but I suspect an official fix might be in order.


#5

Hi,

I was wondering if there were any updates regarding this issue? It would be nice to be able to use VS Code with the Particle Workbench extensions in a corporate setting.

Thanks,

Josh


#6

This is a limitation for all extensions to VS Code. Until support is added for extensions to use the configured proxy server, we’re limited in what we can do, unfortunately.


#7

Anything Particle can do to push them to fix this issue? Based on the comments and age of the Microsoft issue, they are not motivated to fix it.


Login fails behind proxy
#8

Hi @Dillon1337,

We will continue to do our best to raise priority of this issue with Microsoft. There’s actually new work being done on Proxies - see #60773 & #64202.


#9

looks like the new VSCode update (1.30) that dropped today includes some experimental support for extensions :point_right: https://code.visualstudio.com/updates/v1_30#_network-proxy-support-for-extensions

@Dillon1337 maybe give that a try and report your findings?


#10

I had low expectations that this would work, but I am pleasantly surprised. After setting Http: Proxy Support to override, I was able to successfully download and install all of the tools including gcc-arm.

Unfortunately, I cannot login to Particle. I’ve created new topic for that issue: Login fails behind proxy