iPhone app "Could not sign up"

This is what I feared about my initial research into spark.io! But, I eventually gave in and decided to give it a try since the community (and Adafruit) seemed to be accepting it. I got it in the mail today and am so excited to use it. Alas, I install the iPhone app and gets the error below. I can do nothing. Back to my Arduino.

Might I ask what you found that made you fear Particle?

Have you tried closing the app and trying again, because it works perfectly for me, even with a nonsense account and ridiculously short password. Was your internet connection okay, and did your passwords match? If you like, you should be able to setup an account on build.particle.io and use that, it’s the same.

Don’t say such awful things, this is way more fun :innocent:

Hi Bruno,

If you’re sure that your internet connection is working properly this probably means you already have an account with us so you cannot sign up again using the same email, so either tap ‘I already have a Particle account’ below the sign up button or go here:
to reset your password

Good luck

1 Like

Thanks, ido. I did manage to reset my password. That was some awful messaging and should be changed to be more specific. There is a huge difference between not being able to reach the API server and having the server reject the request because the username is already used. The app should communicate that.

What I found was all indications that the investment in hardware and learning was dependent on this new company making enough money to keep the online service alive. And that my ability to program it was dependent on having an internet connection.

Yeah, I tried googling for a way to create an account without the app and couldn’t find it.

I trust that it will be. But, I’ll tell you what isn’t fun is that I’ve been on the move today. (I tend to program in my spare time.) I’ve had to switch wifi networks 3 times in 4 hours. That is really painful. There should be an option in the app to save networks and just switch over instead of going through the new device setup again. I don’t know if the iOS SDK will allow you to see the WiFi SSID name, but if it did that process could be 1 click. (It shouldn’t be automatic because you may want to move your phone between WiFi networks without moving the Particle.

I’m not giving up. I have very high hopes for this platform. I respect the challenges that Particle.io has taken on. There are a lot of never imagined UX paradigms that must be implemented for this thing to succeed. I hope it does. I want this to be the way my children learn to program.

I can’t wait for the Electron to ship! That’s when things will get really fun. (I nearly went the with the Adafruit FONA 808, but can’t accept the 2G only limitation.)

Don’t worry, these are some of the most enthusiastic people I’ve ever met. They too, want nothing more than this to succeed, and they’re pumping in a LOT of time and effort. They’re a new kid on the block, but they’re getting bigger :smiley:!

Yes, and definitely no. You’ll obviously need some sort of connection when you want to program it. If you want to do that wireless, you’ll most likely need internet, or at least wifi. That said, you can also program it over DFU, and this is bound to get more easy, since they’re working on making it so that you don’t need to touch the module to program it.
With the ‘local cloud :cloud:’, there’s also no lock-in. You’re free to take your device off their clouds and host your own. The Particle cloud obviously has a bit more features, and will be updated more regularly, with the latest improvements.
Then again, you can also do TCP/IP or UDP, so no need for a cloud connection if you don’t want to.

Surprisingly, a forum search often works better. For some reason the folks at discourse have found a way to make forum searches not suck, which is admirable. Next time you’ve got problems with anything, I’d suggest searching the forum, then google, and if you still don’t find anything, open a topic. There’s a whole bunch of people willing to help :smile:

What if I told you that was already implemented :innocent:? I suspect that you held the setup button for 10 seconds until it started blinking blue rapidly? That will erase all credentials, forcing you to go through the configuration again. I personally find the CLI more convenient to configure those, since that’s less off a “let’s switch networks a couple of times”.
BUT, next time, try holding the setup button for 3 seconds until it starts blinking blue (the so-called listening mode). Then, enter your new credentials (yet again, I know…). If all went well, they should now be in a FIFO ‘buffer’, through which your device will cycle when looking for networks. The first one it finds that matches one it has in storage, it will connect to. If all is well, you should be able to store 5 credentials that way. Should be enough for your average use case :wink:

I’m glad you don’t, because it’s a great platform, with even greater people :smile: They indeed went through a lot to get this up and running, and it’s amazing to see what they’ve done, what they’re working on, and speculating about what the future might hold.
I still consider myself a kid at 20, and with the Core being my first microcontroller, I can say from experience that this is definitely a way kids can learn how to program :smile:

Indeed they will, exciting times ahead!

Should you require any further assistance, or want some questions answered, feel free to ask away :)!

I absolutely agree. I will fix that.

1 Like

Fixed. Will push app update to App Store this week.

1 Like