Invalid ICCID on non particle Sim

I am trying to set up a particle with a non particle [Telstra, Australia] sim. I have one working but the setup.particle.io is saying that a sim from the same batch is not a valid ICCID? Sim ICCID is 89610180000880889846. My data requirements mean I need to use an non particle sim. Any ideas? No reply from last week when I sent a support email to particle.

I have followed the process previously with a non particle sim that has worked fine. This sim is from the same batch!

  • activated the Sim
  • Data cap is recharged and is sufficient

Just cannot get past the invalid ICCID issue to get the particle claimed and online!

Hey @coldchain – the SIM you provided looks like it is 20 digits long…I know the ICCIDs that we provide are 19. Could that be the issue?

Also, let me know your customer support ticket # and I can check internally on the status.

Hi Will, this is the ICCID that is working 89610180000842978241 and it is 20 digits long. If I truncate the number it still says invalid?

The email doesn’t have a ticket listed:
Hi, there!
Thanks for writing to us! Your email has been entered as a support ticket in our system. If you are getting this email on Monday-Friday, someone is probably already taking a look and sending out happy thoughts while they work on an answer. If you don’t hear from us within 3 business days, please don’t hesitate to write to us again. (Include a picture of a sad puppy to get extra sympathy from your support agent!)
If it’s a weekend or if you need extra speedy tech support, you may want to do a search or start a thread on our community at http://community.particle.io. Not only are the folks there incredibly awesome and nice, but our engineers and support staff are often there as well.
Much love,
The Particle Team
This email is a service from Particle . Delivered by Zendesk

ICCIDs can be 19…22 digits long and need to have a valid checksum.
see e.g.
https://www.justinsilver.com/technology/sim-card-iccid-validation/
http://old.smartjac.biz/products/sim-cards/96-iccid-checksum

And that ICCID does not check
89610180000880889847 on the other hand would :wink:

Thanks for the reply ScruffR but even with the check number added it won’t connect. If I use the number you list (and I have tried with one of the other numbers that it says are invalid) I can get past the ‘invalid’ issue but the sim won’t connect to the cell tower. get a quick flashing cyanblue, the a brief red/magenta, then back to flashing cyan/blue.

This sounds more like a cloud key issue than a problem with the SIM.
Could you try particle keys doctor with that Electron.

Another thing you can try is to swap the SIMs between a working and a not working Electron. The SIM is not actually tied to the device, so they should be interchagable (as long the APN fits to the one set in code).
I’d guess the problem sticks with the Electron and doesn’t travel with the SIM.

1 Like

HI ScruffR, thanks for sticking with this! So the activated Particle Sim works OK when I swap it out so I think at this point it is a problem with the cloud not recognising or supporting a non particle sim. It has been working fine until now so I assume something has changed on the particle side? I can’t use a particle sim as the data costs are far too high for what I need, but it seems that particle is making it had to use a non-particle sim easily?

I don’t think anything has happened on the Particle side according the treatment of 3rd party SIMs, but maybe your provider has enforced some restrictions or that other SIM hasn’t been activated by them yet.
Can you check the SIM with another device (e.g. phone)?

But when I asked to swap the SIMs I actually thought of using the SIM 89610180000842978241 of the same provider that works to exclude a possible factor, not to introduce new factors (like 3rd party vs. Particle).

You said that SIM worked, does it not anymore? But if it does it proves that Particle cloud still supports 3rd Party SIMs.

Thanks ScruffR different issue now…reverted back to particle sim to eliminate sim issue…get breathing magenta but can’t claim the electron…starting to lose a bit of faith in the platform to be honest.

Perhaps I need to hard code the APN into the code to see if that assists as maybe it is a volatile memory issue like some others have had. I am a newbie at this so it could be something simple.

I can see that there is a process to add the hard coded APN but have no idea where it goes in the program

No need to lose faith there since this is most likely not a platform flaw, but might be an innocent Safe Mode issue (actually by design)
This can have two reasons:

  • either you had by accident pressed the SETUP button when powering up (telling the device to go into Safe Mode), or
  • more likely, since you seem to have flashed new code, you by accident/unknowingly targeted a newer system version than your device has got installed on it. And this is the way the device lets you know this.

So either you re-build your project targeting the same version as your system firmware you’ve got sitting on your Electron, or you update the Electron to the most current version (0.5.1), which I’d suggest.

First, if you are going back to the Particle SIM, you won’t need that code at all, since the devices still choose Particle APN by default unless told differently.
But if you actually want to use a 3rd party APN, you’d put these lines at the top of your .ino file.

#include “cellular_hal.h”
STARTUP(cellular_credentials_set(APN, USERNAME, PASSWORD, NULL));

as expained here https://docs.particle.io/reference/firmware/electron/#setcredentials-

1 Like

Thanks for sticking with this. It’s not flashing blue ‘safe mode’ it goes through start up, quick cyan then breathing cyan, not blue. So it can find the cell tower and technically should be claimable. I used the updater to revert to the most recent firmware 0.5.1 I think. I also used DFU mode and did the particle update just to be sure…still breathing cyan but not able to claim it?

Sorry said magenta, I meant cyan…and I am not colourblind…just stupid :smile:

1 Like

How do you try to claim it?
Could it be that you’ve already claimed it?
Have you got CLI installed and running?

Been using setup.particle.io but iSight try to claim it using CLI? Given I’ve on a steep learning curve with nothing to lose I might as well give it a crack!

What OS are you on?
If you are on Windows, there is a quite promising shot of a care-free-all-in-one installer you could give a shot.
I’ve tried it and had no issues with it.

But you could also get away with https://build.particle.io and a serial terminal program like PuTTY

Windows 10 64bit I’ve got cli installed & going fine

Will try to claim through cli

1 Like

Did you have any luck with this?
I’m using a M2M Telstra SIM on the telstra.internet APN and not having much luck.

I think my issue is related to the Telstra SIMs showing their ICCID to the uBlox device with the ‘extra’ digit at the end.

This page here seems to suggest that the extra digit is displayed via the AT!CCID command:
“x = An extra 20th digit is returned by the ‘AT!ICCID?’ command, and is also printed on Telstra SIMs, but doesn’t seem to be an official part of the ICCID (?)”

Is there a way that we can push a ‘non-standard’ ICCID into the firmware download to let us register the device?

You don’t need to use https://setup.particle.io to configure a 3rd party SIM. You can do a manual configuration described here, as well:

https://docs.particle.io/faq/particle-devices/electron-3rdparty-sims/electron/#making-tinker-with-apn-setting

Thank you!!! I had looked everywhere in the Electron reference documentation but couldn’t find what I needed - ‘Register a device manually’.

For some reason the Telstra ICCID’s have an extra digit, confirmed by running particle identify in the terminal.

The setup webpage will not accept the ICCID to help in registering, so I had to add it in manually, which I didn’t realise was possible.

Cheers for the link! Saved me a whole lot of pain and heartache! :smile: