Internet Button LED's stuck on

This was weird.
I made app for each button to turn on 3 LED’s near the button.
Pressing multiple buttons lit multiple LED’s. Pressing 4 buttons worked fine.
worked great.

But sometimes LED’s on left side, especially 7 oclock and 8 oclock don’t work or are stuck on the wrong color.
Cycling power doesn’t help.

How do I unsnap the Photon from the Internet Button shield? Maybe bad connection.

It sits rather tight in the headers and you haven’t got a lot of space to grab the Photon properly, but if you are careful you can pull it out without any risk to damage it.

Unplug the cable, remove the transparent dome, get a wide-ish tool like a plectrum under the short Photon edge near the USB connector and slightly lift just a bit, so that you can get your finger nail under the Photon, then use that tool on the other short edge of the Photon and prise it up a bit and then gently wiggle it out, but keep the Photon as parallel as possible, not to bend the pins.

1 Like