Internet Button DOA?

Folks,
I ordered an internet button a while back and just tried to test it out. It appears to be DOA. When I hook it up via USB i get no lights, and my MacBook does not see a Photon ready to configure. When I pull the Photon out of the button, it lights up fine (blue blink) and behaves properly. Is it possible that I have a bad PCB in my button ? (it says v 1.3.0) Just to be clear, I have the photon installed as it came… on the ‘top’ … i.e. the same side as the LEDs and matched to the outline in the silkscreen. Thanks !
-jc

Hi @johncohn have you tried programming one of the InternetButton library examples on your Photon yet? It does not come pre-programmed with a demo app.

https://build.particle.io/libs/581fb75fdb4a0a21ed0007c6/tab/1_Blink_An_LED.cpp

Here’s the Guide: https://docs.particle.io/guide/tools-and-features/button/photon/

BDub… thanks for responding… I can’t program it in the when installed in the button. the photon is dead when in the socket. it cannot be powered or programmed. FWIW… there appears to be a dead short across the 3.3v and gnd even when I remove the photon from the board. must be a bad PCB
-jc

This has happened before, which is why I’m asking… but are you plugging the Photon into the top side of the button with the LEDs (correct) or bottom side with the buttons (incorrect).

Oh wow… I don’t read much, but when I do I get superpowers!!!

@johncohn that does sound like a bad button PCB then. Please contact https://support.particle.io for a replacement.

1 Like