Installing the USB Driver on Windows & Serial Debugging

When you press w, did you enter SSID, password and security type?

You core should turn flashing colours after the credentials are saved

1 Like

when I pressed w, I got few SSID’s in the local network

Did you press ENTER after entering the SSID, SECURITY TYPE and PASSWORD? sometimes the security type is not displayed.

You should see output like the following:

3 Likes

Yeah got the message and now my spark is breathing cyan :smile: Thanks a lot @BDub now what else i’ve to install?

2 Likes

No problem. If you want reprogram your Core locally you can install a bunch of stuff there… otherwise you’re good to go for flashing OTA from the Spark Web IDE. Did you go there and Add a New Core? You have to have your ID handy since you used the Serial USB method to bring it online you have to type or copy/paste the ID in manually. If you had used the Spark smart config app it does this for you, but I still like the USB method as it seems quicker to setup your credentials.

yeah I got my ID thanks a lot @BDub . But frankly USB method is the best I feel to get connected with the credentials.

2 Likes

Actually initially to program my core I used the code of blinking an LED in the spark web IDE. My core is flashing magenta but the LED I wired to the DO pin not glowing? What to do? Can I actually have the circuit of that.

Thanks in Advance :smiley:

If you are talking about the Blink an Led example that’s in the Spark Web IDE, it toggles the on-board D7 LED and also the D0 output at the same time. If the app programmed and is running properly you will see the on-board RGB LED breathing CYAN and the on-board D7 blue LED blinking at a 0.5Hz rate (1 sec ON / 1 sec OFF). Then you need to hook up an external LED to D0 with a current limiting resistor.

If you use a RED led, the forward voltage is typically 1.7 to 2.0V. So to calculate a current limiting resistor we do a little math. (3.3V - 1.7V) / 5mA = 320 ohms. So grab a 330ohm resistor and you’ll be pretty close to limiting the current to 5mA. Depending on your actual LED, you can get a lot more specific with how much current you drive it with… but don’t exceed the 20mA max output of the Spark Core.

Hook up the 330 ohm resistor to the D0 output, the other end of the 330 ohm resistor to the Anode of the LED, and then finally hook the Cathode to GND.

I’m using a 3leg LED (multi colour) and after connecting the entire circuit only the RGB LED is flashing (Magenta), no response from the external LED hooked up at D0, I’ve connected the 330Ohm resistor from D0 to the anode at the GND. What to do?

So when you flash the Core Over the Air (OTA), it flashes Magenta while that’s happening. This can take up to 45seconds or more before it finishes, resets itself and reconnects to the WLAN and CLOUD. Does it just blink magenta forever? Describe your OTA process… starts with Breathing Cyan hopefully, you Flash the code to your Core and it starts blinking magenta… but then what? How long do you wait and what do you do next?

1 Like

No actually it working now did factory reset for around 15 times and DFU then it got connected :smile: And previously I didn’t connect the GND pin to ground, so the LED didn’t glow, but now it’s freaking awesome :smile:. Thanks a lot spark Community team, probably the only team which responds like hell fast to a problem.

All The Best

3 Likes

@anirudh it’s great to get that kind of feedback, thanks and have fun coding up some cool projects with your Spark Core :spark:

2 Likes

I had the exact same problem as @Craigjones and @crstffr, and once I changed the USB cable it worked like a charm as well. Also fixed a problem where my Core was resetting every time I bumped it. I guess the USB cables that ship with the Core aren’t worth much.

I got problems when I was trying this on a connected P1-module. I could not get the COM-port to appear. When I tried to install the downloadable driver, it failed. Then I realized that the P1 has a different USB ID then the Photon so of course, it will not work. I changed the .inf-file and that solved it.
So I think there should be an added driver version for the P1 to avoid this kind of trouble.
Or is there another version that I have missed @BDub?

Very interesting @janne68… I’ll file an issue to get this resolved, thanks!!

For those connecting P1’s here’s the lines that need update in photon.inf renamed to P1.inf:

[DeviceList.NTx86] 
%DEVICE_DESCRIPTION%=DriverInstall, USB\VID_2B04&PID_C006

[DeviceList.NTia64] 
%DEVICE_DESCRIPTION%=DriverInstall, USB\VID_2B04&PID_C006

[DeviceList.NTamd64] 
%DEVICE_DESCRIPTION%=DriverInstall, USB\VID_2B04&PID_C006

[DeviceList.NTARM] 
%DEVICE_DESCRIPTION%=DriverInstall, USB\VID_2B04&PID_C006

I suggest P1.inf should be included in https://s3.amazonaws.com/spark-website/Spark.zip download to save the trouble.

3 Likes

Don’t know if anyone has tried it, but I had this page pulled up when about to connect my old Spark core to my fresh install of Windows 10. Glad to know that once I got it connected to the wifi through the tinker app on my phone, I was able to see the COM port without any special drivers. Opened Putty, connected to COM3 @9600 and i’m up and running. Finally something that works right on Windows 10.