Installing official Particle drivers breaks USB HID functions

I was ripping out my hair with this issue, since things used to work when I last tried, but when revisiting the topic it stopped working and I couldn’t understand why.

I am reworking my PS2Communication library for Libraries V2.0 to incorporate the HID USB Mouse features into the demo, but I couldn’t get the mouse pointer to move although the serial output indicated things worked as expected.
But then I remembered that when that HID USB feature was first introduced one had to remove all the old Particle Serial Drivers and install new ones to get things to work. So I removed them and voi la it worked again, but now the serial output was broken. So I installed the newest drivers via

So now I had two serial ports for my Photon but no USB HID anymore.
Used the installer to remove the drivers again and HID was back and Serial gone - that’s rather annoying!

BTW: My system is Windows 8.1 Pro 64bit (Win 10 Pro 64bit to be tested next)