If electron set to one apn , electron working for other sim card also

if i set apn to “airtelgprs.com” and download “firmware.bin” to electron it works ok , but when i insert other sim card to the same electron WITHOUT changing apn , electron also works ok , so how it is possible?
can anyone explain me please

Are you saying that the SIM card are from different telco?

yes exactly,
from different telco

When you say works ok, it is breathing cyan?

yes i am using Particle.publish() in app , it publishes events and breathing cyan also

Did you completely power down the Electron, including removing the battery, when switching the SIM?

If you just reset the Electron using the RESET button or flashing software, the saved modem state in the modem is reused, and it’s probably still connecting to the first telco.

Did you completely power down the Electron, including removing the battery, when switching the SIM?
—> yes,completely turned off electron by removing battery and also USB power

checked many times on a number of electron boards, electrons works ok without changing apn

That’s strange then. Normally an APN is required, unless it one of the built-in ones. The Particle SIM card is built-in, as is the Twilio SIM. Most other SIMs require an APN.

its weird behavior of electron

Another reason might be a cooperation between providers.
I’ve got a SIM card that works without setting the APN at all, but I know the provider has got a cooperation contract with the carrier Particle SIMs are using.
The only thing that doesn’t work is the long keepAlive with that SIM.

1 Like

it may be the reason for this…

but i have tried with up to 4 different SIM cards on same electron boards