I think I broke my argon

Tags: #<Tag:0x00007fe21f79a280>


I just got an Argon kit, registered/initialized the Argon etc, etc.

All was well until I tried to compile and flash the ‘the blink an led’ app to the Argon. Thru what I assume was a combination of pilot error and unfamiliarity with the new Workbench, whatever I flashed to the Argon has seriously confused it. It’s blinking the red SOS, with what looks like 10 blinks - ‘Assertion Failure’.

I’ve tried every dfu update/factory reset variation I could find in the Particle docs and in the forums, but 10 red blinks is where I end up. Particle Doctor doesn’t work, I believe because it is not yet available for the Argon.

Does anyone have any suggestions on how I can maybe get this part back among the living?



Have you tried safe mode to circumvent your firmware?


This page explains Argon Status LED states. https://docs.particle.io/tutorials/device-os/led/argon/.

SOS is no big deal. There are a number of different causes which are explained on this page.

To recover, look for “Safe Mode”, flashing Magenta, and follow the instructions for putting your Argon into Safe Mode. Once the device is in Safe Mode, it can be reflashed.



Tried that. Several times.

https://docs.particle.io/tutorials/device-os/led/argon/#safe-mode sez:
To put your device in Safe Mode:

  1. Hold down BOTH buttons
  2. Release only the RESET button, while holding down the MODE button.
  3. Wait for the LED to start blinking magenta
  4. Release the MODE button

When I execute Step 4, the LED flickers dim red for a bit, then very very briefly flashes - magenta -red/blue both (at least I think its magenta, it goes by pretty fast), then back to red SOS and 10 red blinks.

Whatever I did to cause this has the Argon seriously confused

But thanks for the suggestion


Can you put the Argon in DFU mode?

Flashing tinker or a blank app should fix it.


My guess is that you are holding the MODE button too long after you release the RESET button. I release mine as soon as I see the status LED flash after I release RESET, and I rarely have a problem. That said, DFU is another opton, and you may find it easier.



I can put the Argon into DFU mode, and…

Due to no cloud connectivity, I must flash apps from Workbench. Which says the app flashed OK, but still red SOS

I can ‘flash --usb tinker’ and get ‘success’ from the terminal, but… red S0S on the Argon
I tried ‘flash --usb argon-tinker@1.2.1-rc.2.bin’ and… same results - red SOS on the Argon

Whatever is wrong with this part does not seem to respond to the usual fixes.

Is there any practical way I can directly access and update memory locs to trick this part into thinking it’s fresh from the factory?

Thanks again for your help


DFU mode works well for this. Do you have the CLI installed on your computer?


You can try resetting the device by putting the device into Listening Mode and then press/hold the MODE button for 10+ seconds still the LED starts fast flashing blue.
Then run particle serial inspect and post the output for details about the possible cause.

After that put the device into DFU Mode and run these

particle flash --usb tinker -v
particle update -v
particle flash --usb tinker -v


Just saw these responses. Thx.

I do have dfu-util - tried to load:
‘dfu-util -d 2b04:d00c -a 2 -s 0x80200000 -D argon-tinker@1.2.1-rc.2.bin’
as per: https://docs.particle.io/tutorials/device-os/led/argon/

Then I followed the reset steps.

And…red SOS

And ScruffR, the only state available to me on the Argon is DFU Mode ‘blinking yellow’. It’s either that or red SOS

Bottom line, I think I’ve tried the above suggestions, plus everything I can find in the Particle documentation (and the forum) and to restore the part’s sanity, but nothing is working.

I’m frustrated enough at this point to mess with memory directly using dfu-util, but I have no experience with/knowledge of the memory map and don’t even know if such an approach is possible.

I’m also frustrated enough to trash the part and purchase another one, but I notice they are sold out in the Particle store. Grrrr.


You can also file a support ticket at support.particle.io


Thanks ScruffR - I’ll head there next

And thanks to all who sent suggestions my way


I was in the same situation these past several days… I tried some new code to modify Wifi credentials in the STARTUP call (executes before connections are made) and ended up bricking the Argon… I tried everything I could to restore it including all the suggestions in the forums and using DFU commands like ‘particle device doctor’, flashing the latest .bins (all of them) … I saw this post and noted the one command I hadn’t tried: ‘particle update -v’ and damn if that didn’t work! Thank you @ScruffR for posting that…


Same here. I tried all kind of different things including flasshing via dfu-util and nothing worked. Till I found this post. and the particle update -v was the one that fixed it. Thanks.


If you’re really borked you guys can try the procedure here:

This is for when DFU doesn’t work. The procedure erases, writes the Soft Device, bootloader and then the system part and Tinker app. It doesn’t matter how borked your device is (firmware wise). You should always be able to get it back running shape.

P.S. this works for all Particle Mesh based devices with the NRF52840.